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About CADtools 8
Welcome to Hot Door CADtools, a full-featured CAD plug-in 
for Adobe Illustrator CS3, CS4, CS5, CS6 and CC. CADtools 
offers an easy and elegant solution for designers who need the 
precision of CAD within the flexible, creative environment 
of Adobe Illustrator. CADtools 8 does not require a subscription.

Major improvements in CADtools 8
• CS6/CC compatibility and interface integration - 
Only version 8 of CADtools will work with Illustrator CS6 and CC 
• Hot Door CORETM - New COde REsource architecture increases 
plug-in performance and facilitates rapid development of 
CADtools upgrades and future productivity plug-ins
• CADcontrol bar - Quick access to popular CADtools settings
• Attached dimensions/labels - This CADtools Preference  
instantly updates dimensions when editing their linked objects
• Corner Profile tool - Finish corners with decorative shapes 
with this tool in the CADediting tool group 
• Rounded Rectangle tools - Create rectangles with 
rounded corners
• Chain Datum Dimension and Axonometric Chain 
Dimension tools - These tools replace the settings to make 
datum dimensioning easier
• Improved Trim and Extend tools - These editing tools are 
improved with smoother, more predictable results
• Additional label tool and options - A multiple leader label 
and expanded CADlabels panel provide greater control and style 
of CADlabels
• CADunits panel - All units for dimensions and CADtools 
interface are now controlled from one panel
• CADdimensions panel combines the former CADtext and 
CADstyle panels
• CADaxonometric panel replaces the former CADisometric 
panel with unlimited custom axonometric views
• CADscale panel replaces the former CADdocument panel and 
features an unlimited number of custom scales
• CADlabels panel defines label terminators and text separate 
from dimensions
• CADtools Preferences under the Window > CADtools menu 
replaces settings in the former CADdocument panel
• Show/Hide All CADtools panels under the Window > 
CADtools menu
• Improved speed and acccuracy of CADtools fillet tool with 
fillets as small as 2 px radius
• Integrated scaled CADrulers and CADgrids replace the 
former CADrulers layer and CADgrids layer
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Major features of CADtools 8
CADtools includes 76 drawing, dimensioning, labeling and 
editing tools organized in eight groups under the Illustrator 
tools. Ten panels (formerly called 'palettes') are available from the 
Window > CADtools menu. CADtools panels edit document scale, 
objects, dimension and label styles, and provide shortcuts. 

Drawing
• Precision drawing tools for 2D and axonometric/isometric 
objects
• Standard or custom scale defined per document or 
per Illustrator layer, including a scale calculator
• Integration of scaled Illustrator grids and rulers
• On-screen info while dragging objects in scale with 
optional full-screen cursors
• Compatible with Illustrator Smart Guides
• Wall tools with sliding editability and door/window insertion
• Customizable title blocks and tables

Dimensioning
• Complete linear, curvilinear, angular and radial dimension tools 
to measure points, lines, or datums
•  Live dimensions and labels link to objects and respond 
to artwork changes
• Dimensions show measurement or custom text
• Automatic dimensioning of document or objects
• International number format support
• Dual dimensioning and tolerancing
• Chain and datum dimension tools

Labeling
• Auto-labeling with text, numbers, alphabet or object geometry
• Custom dimension and label styles

Editing and measurement
• Scaled move, transform and repeat
• Instant calculation of area, perimeter, length of path(s)
• Area transform
• Corner Profile tool
• Path division for cutting or marking any path
• Measure Scale tool - similar to a map's scale
• Measure Distance tool
• Proportion tool - resize an object to another's dimensions
• Smart Trim and Extend tools

Shortcuts and presets
• Optional shortcuts to globally control all CADtools units
• Globally save and load CADtools panel settings as presets

Using CADtools with Adobe CC memberships
Adobe Creative Cloud (CC) is time-based, membership access to 
the latest versions of Adobe Illustrator and other Adobe programs. 
While Hot Door does not offer subscriptions for use of CADtools, 
the plug-in remains compatible with both traditional and 
subscription-based versions of Adobe Illustrator. When using 
Adobe Illustrator CC, the Adobe software is installed directly on 
the computer as before but requires online access every 30 days 
to update membership and obtain minor software updates. 
CADtools 8 follows the traditional model, running directly 
on the computer hard drive. On launch, CADtools 8 uses the 
Internet to check for compatibility with Illustrator and allows 
for automatic updates to ensure seamless workflow. 

Free updates for CADtools 8
Software updates feature minor bug fixes and enhancements 
between major upgrades of the software. Major upgrades are 
numbered releases such as 7, 8 or 9. Updates are dot releases 
such as 8.1, 8.2 or 8.3. CADtools 8.x updates will be available 
for free at www.hotdoor.com, while upgrades such as version 9 
will require purchase. This policy is adopted by most software 
companies including Adobe.

CORE technology in CADtools 8
The new Hot Door CORETM (COde REsource) architecture 
dramatically increases performance and allows for rapid 
integration of new features and enhancements. CORETM ensures 
that new, compatible versions of CADtools will be accessible to 
Creative Cloud users who require prompt upgrades to the next 
version of Adobe Illustrator. CORETM also promises a reliable 
technology for new productivity tools for design professionals.
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Updating or installing CADtools

On Mac OS X
1. If Adobe Illustrator is currently running, quit the application.

2. If CADtools has been downloaded, the file will be zipped. 
Double-click CADtools8.dmg.zip to unzip it.

3. Double-click CADtools8.dmg. Follow the on-screen instructions 
to install the file for your version of Adobe Illustrator. Drag the 
icon named CADtools.aip into the Adobe Illustrator > Plug-ins > 
Tools folder. This will replace any older files with the same name. 
Then proceed to step 4 below.

On Windows
CADtools 8 installs differently on 32-bit and 64-bit Windows 
machines. If the C drive has two folders called Program Files 
and Program Files x86, then the system is 64-bit. The 64-bit 
version of Adobe Illustrator will be installed in Program Files, 
and the 32-bit version will be installed in Program Files x86. 
If there is only a Program Files folder, then the system is 32-
bit. Follow instructions below to complete installation. 

1. If Adobe Illustrator is currently running, quit the application. 

2. If CADtools was downloaded online, the file will be zipped. 
Double-click CADtools8.zip to unzip it.

3. Double-click Install Hot Door CADtools.exe. Follow the 
on-screen instructions to install the file named CADtools into 
the Adobe Illustrator > Plug-ins > Tools folder. 

4. When launching the Adobe Illustrator application again, 
a CADtools Personalization dialog will appear. For purchased 
upgrades, enter the new CADtools 8 upgrade serial number, 
and then enter the CADtools 5, 6 or 7 serial number when 
prompted. For full versions, enter the new CADtools 8 full 
version serial number.

5. If there is a need to open older CADtools files created with 
Adobe Illustrator CS2 or previous versions, please follow 
instructions on page 10, "Converting CADtools files with 
Legacy Text." 

After installing CADtools, regularly check for the latest 
update by selecting Window > CADtools > Check for 
Updates. 

Personalizing, registration and support

Personalization:
For the full version of CADtools 8, enter the CADtools serial 
number (with a format XXX-X-X-#-XXXXXXXXXXX) and click OK. 
If multiple licenses have been purchased, enter a multi-license 
serial number. Illustrator will open and CADtools icons will 
appear at the bottom of the Illustrator tool panel. The CADtools 
icons have red point markings.

To use the demo version of CADtools, click the Demo button. 
CADtools will function for an unlimited time period but limits 
drawing and dimensioning to 1:3 scale with access to only the 
top tool in six of the eight tool groups. The labels are limited 
to a curved leader and a circular border, and all label values will 
read "Demo."

To purchase the full version of CADtools, click the Purchase but-
ton to launch the Hot Door website and store.

Registration:
To be eligible for free technical support, information on 
upgrades, and other special offers, please register CADtools 
online at www.hotdoor.com  If CADtools was purchased directly 
from Hot Door, registration is not necessary.

Technical support online:
Registered users are entitled to free email or phone technical 
support. Get fast, friendly help from people in California by call-
ing toll-free at 1-888-236-9540. Choose Window > CADtools > 
Technical Support to link directly to the tech support web page.

Online tutorials:
Choose Window > CADtools > Online tutorials... to view video 
demonstrations and tool animations. 

To reinstall CADtools, download the demo version from 
the CADtools > Free Demos section at www.hotdoor.com. 
Serial numbers can be retrieved from the website using the 
email address from the original order.
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Working with older versions of Illustrator

Converting CADtools files created with Legacy Text 

When opening older files created with CADtools, dimensions will 
not remain live within CADtools 8. Follow the instructions in the alert 
dialog box and save a backup copy with former live/attached data.

Pending 8.x updates of CADtools may improve file conversion, 
and information on these updates can be found on the 
www.hotdoor.com website.

Using files created with older versions of CADtools

When opening older files created with CADtools, scale will be
retained but dimensions will not remain live or attached in CADtools 8.  

 

Overview of the CADtools interface

Finding the tools
After properly installing CADtools and launching Adobe 
Illustrator, new CADtools drawing and dimensioning 
tools will appear in the tools panel of Adobe Illustrator. 
Within the eight tool groups in the toolbox, there are 
76 popout tools. Select the small arrows on the right 
of the tool icons and drag to highlight other tools. The 
tool groups can be separated by dragging the tearoff 
icon at the end of each set of hidden tools.

Color icons and tool behavior
CADtools icons are distinguished by their red point 
markings. The red points indicate the position of 
mouse-click(s) in relationship to the artwork 
created. Tool icons that have only one red point 
require only one mouse-click or click-and-drag. Tool 
icons which have two red points require two mouse-
clicks positioned on artwork as shown in the icon. For 
most of these tools, drag the mouse after the second 
click. The fillet, chamfer, trim, extend and proportion 
tools do not require dragging after the second click.

Window > CADtools panels
Use the Window menu to access ten CADtools panels, 
CADtools Preferences, and CADtools web pages for 
tutorials, tech support, and updates.
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Overview of the CADtools interface (cont.)

The ten panels in CADtools are essential for controlling the 
appearance and creation of CAD artwork. To view and select one 
of these panels, choose Window > CADtools.  

CADcontrol Control panel displays for quick access 
		  to settings for current tool. 

CADaxonometric Controls isometric/axonometric angles and 
		  allows one-click projection and flattening of 
		  artwork between 2D and axonometric views.

CADdimensions Sets the appearance and text options for 			 
		  dimensions (formerly CADtext and CADstyles).

CADguides Provides control of CADgrid and CADruler 
		  settings as well as full-screen cursors.

CADlabels Sets the appearance of labels and 				 
		  options for automatic labeling including
		  custom text, alpha or numeric increments,
		  and object geometry data.

CADscale Defines document-wide or layer-based scale
		  Set any number of custom scales.

CADshortcuts Loads and saves CADtools panel settings as 		
		  presets and applies automatic dimensioning. 	

CADtracker Displays geometric data for CADtools artwork 		
		  (including location, length, perimeter and  
		  area), transforms objects/area in scale, moves 		
		  objects in scale, and repeats objects in scale.

CADunits Defines all units including dimensions, 
		  numeric input, CADrulers, and CADtools 
		  panel fields.

CADwalls Sets the thickness of walls and how they are 		
		  measured (from inside, center or outside).

Dock or stack CADtools panels similar to other Illustrator panels. 
To add a CADtools panel to the icon dock in Illustrator, click and 
drag the title to the dock. CADcontrol can be docked above or below 
Illustrator's control bar.

Setting up the plug-in preferences

Before working with CADtools, check CADtools Preferences and 
define settings that affect the behavior of tools. Most settings 
were controlled by the CADdocument panel in previous versions of 
CADtools. Choose Window > CADtools > Preferences...

• Panel settings retain the settings of selected artwork similar to Illustrator. 
If unchecked, panel settings will return to their original state after art is 
deselected.

• Automatically check for free updates for the installed version of CADtools at 
different times – at launch, daily, weekly, or monthly.

Using attached dimensions/labels
Dimensions that have been created with Attach dimensions/labels 
to objects checked will automatically follow their attached objects 
as they change in scale and location. Dimensions can be attached 
to a placed image by dimensioning points along or within its bound-
ing box. Attached dimensions and labels can be edited with the CAD-
dimensions, CADlabels, and CADunits panels. Dimensions created 
with this option unchecked cannot be reattached or edited with 
CADtools panels, but they can be edited with Illustrator's tools.

To detach a dimension, select it and click the Detach button in 
the CADdimensions panel. To detach a label, select it and click the 
Detach button in the CADlabels panel. Dimensions and labels are also 
detached from their objects when dimension artwork is ungrouped.  

To duplicate an object with attached dimensions, copy and paste 
the object with its dimensions. If the dimension layer is locked 
and objects with attached dimensions are moved, then the affected 
dimensions will be detached from their objects.

• Comma or decimal number 
format applies to all dimension 
text and numeric input.

• The thousands separator shows 
the comma in dimensions.

• A dimension layer organizes 
dimensions in their own layer.

• Attached dimensions/labels can 
attach to objects and follow them 
if they are relocated or resized. 
See details below. 

• CAD drawing tools create 
groups with paths in Layers 
instead of paths alone.

• Y axis increases going down to 
follow Illustrator unless this is 
checked.
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Setting up the document: Scale
Using CADscale
CADtools drawing and dimensioning tools can create artwork 
using scale so that larger or smaller-than-life drawings are easily 
represented on screen or paper. To set the scale for the document 
or individual layers choose Window > CADtools > CADscale. 

Document-based scale
Choose Document-based scale 
for scale that affects artwork 
on all layers of the document. 
1. Select a Scale from the scroll-
ing Scales list. Scales are arranged 
as architectural, engineering and 
custom scales in the scrolling list. 
The Scale Calculator can be used to 
determine the best scale as needed.
2. Click Apply to set the scale.

Layer-based scale
Choose Layer-based scale to 
define a scale for each layer of 
the document. 
1. Select the layer from the Layers 
list in the CADscale panel. 
2. Select a Scale from the scrolling 
Scales list.
3. Click Apply to set the scale.

Note about drawing with scale: Since scale affects only CADtools 
drawing, editing, labeling and dimensioning tools, remember to use 
the CADrulers, CADgrids, and CADtracker to monitor values in scale. 
Object artwork is not affected by changes in scale - only dimensions 
and measurements are affected by scale. Changing scale does not 
resize artwork.

Setting up the document: Scale (cont.)

To add a new 
custom scale 
1. Select the new 
scale icon at the 
bottom of the 
CADscale panel.
2. Enter an 
Absolute scale 
equation or a Ratio 

scale equation. The Scales menu supports an unlimited number of 
custom scales.
3. Click Apply to set the selected scale.

To delete a custom scale
1. Select the scale in the CADscale menu.
2. Click the delete button in the CADscale panel.

To edit a custom scale
1. Select a custom scale from the bottom of the CADscale list.
2. Click the edit button in the CADscale panel and change the 
scale equation to a new custom scale.
3. If the new custom scale should be applied to the entire 
document, choose document-based scale and click Apply to 
set the scale.
4. If the custom scale should be applied to a layer, choose layer-
based scale and select the desired layer in the CADscale menu. 
Click Apply to set the custom scale for that layer.

• Edit, new custom scale and delete 
buttons help manage scales in the list.

• Edit, new custom scale and delete 
buttons help manage scales in the list.
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Setting up the document: Scale (cont.)

Using the Scale calculator
When using Document-based scale, use the Scale calculator to 
create a custom or 'best fit' scale and resize artwork based on a 
selected object's dimensions. Before using the Scale calculator, 
make sure Document-based scale is selected in the CADscale 
panel. Select the object used as a reference for the scale 
calculation, then click the Scale calculator button.

In Step 1 of the Scale Calculator dialog, choose the selected ob-
ject's width or height as the reference value, then enter a desired 
real-world value on the right. 

In Step 2 of the Scale calculator, choose how the new scale will 
affect the art and scale. 

Option 1: To let the Scale calculator determine a preset scale 
that best fits the scale equation, choose Apply preset. Select 
Architectural scale or Engineering scale based on the type of 
project. Then select an option to resize the artwork to best fit 
the artboard, a specified width or a specified height. If choos-
ing width or height, enter a value in the adjacent field.
Option 2: To select a preset scale, choose Apply preset scale. 
Artwork will be resized.
Option 3: If the artwork should not be resized, choose Create 
and apply a custom scale from the scale equation. A new 
custom scale will appear in the CADscale panel, and artwork 
will not be resized. This option may be useful for fitting art-
work on a certain size of paper. 

Apply preset and resize art when a standard scale and size of art are 
most important:

Use preset scale when a specific scale value is most important:

Use custom scale from equation if the art should not be resized:

27 ft - 2 in

0 in

36 ft - 6 in 13 ft - 11 in

50 ft - 5 in

6.5 ft 

4.5 ft 

May not fit in artboard perfectly,
but scale is standard

Scale can be any value, which may be 
useful for fitting the artwork perfectly 
inside the artboard

Resizes art to match preset scale
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• Show CADgrids and Show CADrulers 
display special scaled grids and rulers 
for use with CADtools.

• Snap to grid to snap the cursor 
to grid lines and intersections while 
using CADtools drawing tools

• Units and precision settings for 
CADrulers are set in the CADunits 
panel.

Hot Tip! Use both CADtools 
full screen cursors and 
Adobe Illustrator Smart 
Guides to create, edit and 
transform CADtools objects 
with precision.

• Show Full screen cursors for 
easy precision drawing with CADtools.

Setting up the document: CADguides
The CADguides panel establishes special grid and ruler settings 
for use with CADtools. The origin for CADrulers is defined by the 
Illustrator's ruler origin. The origin is unique to each artboard. 

Setting up the document: CADunits
Use the CADunits panel to set up units and precision for all 
dimension values and interface settings like numeric input, 
CADrulers and CADpanel options. Choose Window > CADtools > 
CADunits. CADtools supports these units:

• Set units, precision, and tolerance 
for dimension measurement values. 

• Check Append to show the units 
after the dimension value (see sample 
below)

• Select the ( ) option to show 
reference dimensions within 
parentheses (as approximations).

 • Check Shift to display tolerance as 
a smaller font size shifted up from 
the baseline.

• If Dual dimensions is checked, 
dimensions will display an upper and 
lower value that is useful for display-
ing measurement in two different for-
mats. Units, precision and tolerance 
also will be definable for the lower, 
secondary dimension values. 

No options selected Precision set to 0

Dual dimension selected

Tolerance also selected

Append selected

( ) selected

3.881

3.881 cm

(3.881 cm)

3.881 cm
1.528"

3 cm

3.881 cm ±0.1
1.528"

Sample results of different CADunits settings
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Setting up the document: CADunits (cont.)

CADtools supports these units: 
Points: pt
Pixels: px
Picas: p
Millimeters: mm
Centimeters: cm
Meters: m
Kilometers: km
Mils: mil
Decimal inches with symbol: X.X“
Fractional inches with symbol: X X/X“
Decimal inches with units: X.X in
Fractional inches with units: X X/X in
Decimal feet and inches with symbol: X' X.X“
Fractional feet and inches with symbol: X' X/X“
Decimal feet and inches with units: X ft X.X in
Fractional feet and inches with units: X ft X/X in
Decimal feet with symbol: X.X'
Decimal feet with units: X.X ft
Miles: mi
 	

If Follow primary dimension units is un-
checked, specific units can be defined 
below:

• If this is checked, interface settings 
including numeric input, CADrulers, and 
other CADpanels fields will follow the 
units set for primary dimension values.

• Set units and precision for default 
numeric input values in dialog boxes. 

• Set units for CADrulers and CADgrids 
to show the units after the dimension 
value.

• Set default units for other fields 
inside CADtools panels. All line weights 
and fonts default to points.

Setting up the document: CADcontrol
Similar to the Illustrator Control panel, CADcontrol displays 
CADtools options for the current tool. Choose Window > CADtools 
> CADcontrol. CADcontrol changes contextually depending on the 
tool selected. 

While using CAD drawing tools...

While drawing CADwalls...

While using dimensioning tools...

While creating CADlabels...

The CADcontrol panel can be dragged to dock to the top or bottom 
of the workspace. To detach the CADcontrol panel, drag the bar on 
the left side of the panel.
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2D CAD drawing tools

Orthographic drawing tool group:
Click once on the document to input values numerically.

CAD Rectangle - Click and drag to create the shape.
CAD Centered Rectangle - Click and drag to create the shape.
CAD Ellipse - Click and drag to create the shape.
CAD Centered Ellipse - Click and drag to create the shape.
CAD 3-point Circle - Click three points to create the circle.
CAD Arc by Radius - Click origin point, then click and drag 
another point to define the endpoint and radius of the arc. Click 
the second point without dragging to input values numerically.
CAD Arc by Points - Click origin point, then click and drag 
another point to define the endpoints and curvature of the 
arc. Click the second point without dragging to input values 
numerically.
CAD Line - Click and drag to create the line. Click and drag 
from the endpoint of a line path to continue the line. Shift-alt/
option drag to create axonometric lines as defined in the 
CADaxonometric panel. Shift-drag to constrain to 45° angles. 
Control-drag after starting the line to constrain the line to the 
current angle. Click once with this tool on the document to en-
ter line values numerically, including rise and run. Double-click 
the CAD Line tool icon to define settings that automatically 
connect paths and draw only at constrained angles. 
Tangent & Perpendicular Line - Click a curved path or ellipse 
and drag out to create a constrained line that is tangent or 
perpendicular to the path.
Offset - Click a path and drag to create a scaled offset at the 
distance displayed while dragging. Scale is defined in the CAD-
scale panel and displayed units are defined in the CADtracker 
panel.

Hot Tip! Choose View > Smart Guides to help create CADtools 
objects with more precision. Use CADgrids, CADrulers and 
CADtracker panels to finely control object size and placement.

2D CAD drawing tools (cont.)

CAD Rectangle 
Select the CAD Rectangle tool and place the cursor at the 
desired corner of the rectangle. Click and drag from one 
edge of the rectangle to the opposite edge. Hold down the 
shift key while dragging to create a square.

Note: To quickly toggle between the Rectangle and Centered 
Rectangle, use the alt/option key. To numerically create a 
rectangle in scale, click once on the document.

CAD Centered Rectangle
Select the CAD Centered Rectangle tool and place the 
cursor at the desired center of the rectangle. Click 
and drag from the center of the rectangle to the 
edge. Hold down the shift key while dragging to create 
a square.

CAD Rounded Rectangle 
Select the CAD Rounded Rectangle tool and place the 
cursor at the desired corner of the rectangle. Click and 
drag from one edge of the rectangle to the opposite edge. 
Hold down the shift key while dragging to create a square.

Note: To quickly toggle between the Rounded Rectangle 
and Centered Rounded Rectangle, use the alt/option key. 
To numerically create a rectangle in scale, click once on the 
document.

CAD Centered Rounded Rectangle
Select the CAD Centered Rounded Rectangle tool and place 
the cursor at the desired center of the rectangle. Click and 
drag from the center of the rectangle to the edge. Hold 
down the shift key while dragging to create a square.

CAD Ellipse 
Select the CAD Ellipse tool and place the cursor at the 
desired edge of the ellipse. Click and drag from one edge 
of the ellipse to the opposite edge. Hold down the shift 
key while dragging to create a circle. 

Note: To quickly toggle between Ellipse and Centered ellipse, 
use the alt/option key. To numerically create an ellipse in 
scale, click once with the CAD Ellipse or Centered Ellipse 
tool.
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2D CAD drawing tools (cont.)

first 
click
once 

then sec-
ond click 
and drag
counter-
clockwise

first 
click 

second 
click then 
drag back 
and forth

first click 
and drag

release mouse 
button, click 
endpoint, then 
drag - continue 
and close the 
path by clicking 
on the first 
point

CAD Centered Ellipse 
Select the CAD Centered Ellipse tool and place the 
cursor at the desired center of the ellipse. Click and 
drag from the center of the ellipse to the edge. Hold 
down the shift key while dragging to create a circle.

CAD 3-point Circle 
Select the CAD 3-point Circle tool and click three 
points to define the boundary of the desired circle. 
Any circle can be defined by three points. The third 
point can also be dragged.

CAD Arc (by Radius)
Select the CAD Arc (by Radius) tool and position 
the cursor at the desired center of the arc. Click the 
mouse button once and release. Then position the 
cursor where the arc should begin, which will be 
the length of the arc radius. Click and drag counter-
clockwise to create the arc. Hold down the control 
key while dragging to draw the opposite arc.

Note: To quickly toggle between Arc (by Radius) 
and Arc (by Points), use the alt/option key. To 
numerically create an arc (by radius) to scale:
1) Click once to begin the arc
2) Click once anywhere on the document
3) Enter the values and units for the arc

CAD Arc (by Points)
Select the CAD Arc (by Points) tool and position the 
cursor to begin the arc. If this is an anchor point, 
the cursor will change to (      ). Click the mouse 
button once and release the mouse button. Position 
the cursor where the arc should end. Click and drag 
back and forth to create the arc. Hold down the con-
trol key while dragging to create the opposite arc. 

To numerically create an arc (by points) to scale:
1) Click once to begin the arc
2) Click once where the arc should end
3) Enter the values and units for the arc radius

2D CAD drawing tools (cont.)

CAD Line
The CAD Line tool displays the line while 
dragging to create it and join it to other lines. 
View Illustrator's Smart Guides for snapping and 
aligning CAD lines with other paths and objects.

Select the CAD Line tool and position the cursor 
at the start of the line. Click and drag to position 
the line, then release the mouse button to create 
the line. Hold down the control+shift keys while 
dragging to constrain the tool to multiples of 45°. 

For axonometric lines, hold down the shift+alt/
option keys while dragging to constrain the tool to 
the current axonometric angle. Axonometric lines 
will not automatically update with changes to the 
axonometric view. Be sure to set up axonometric 
view angles with the CADaxonometric panel before 
creating axonometric artwork with the CAD Line.

To create polygons with the line tool, create a 
line, then position the mouse over an endpoint of 
the line. When the (      ) cursor appears, begin 
dragging to create a new line joined at that end-
point. Release the mouse button when the line is 
positioned and continue the process as needed. To 
close the path, click and drag the final line until 
the cursor is over the first anchor point of the 
polygon. When the (      ) cursor appears, release 
the mouse button and the polygon will close itself.

To view geometry while dragging, check Show 
geometry while dragging in the CADtracker panel.
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2D CAD drawing tools (cont.)

To draw lines connected, double-click the CAD Line 
tool and select Connect paths (checked by default). 
Lines will connect while drawing, which is unlike 
Illustrator's Line tool. To draw lines with segments that 
are not connected, uncheck this option.

For persistent constrained lines, double-click the CAD 
Line tool and set the angle of constraint in the CAD 
Line Settings dialog. All lines will constrain to this 
angle and its opposite angle. Hold down the control 
key to draw any angle, and hold down control+shift to 
constrain to increments of 45°.

For dynamically constrained lines, double-click the 
CAD Line tool, uncheck the Constrain setting in the 
CAD Line Settings dialog, and select OK. Then select 
the CAD Line tool and start dragging a line at any 
angle. To constrain that angle, hold down the control 
key after dragging.

For draw lines numerically, including rise/run: To 
numerically create a line in scale, click once on the 
document with the CAD Line tool. Enter values in Rise 
or Run fields to automatically calculate the angle for 
the line.

2D CAD drawing tools (cont.)

Tangent & Perpendicular Line 
To create a line tangent or perpendicular to a path, 
select the Tangent & Perpendicular Line tool and 
position the cursor over the path at the desired location. 
When the (      ) cursor appears, click and drag in the direc-
tion the line should appear. The line will constrain to tangent 
or perpendicular angles to the path.

Offset
To offset any path, select the Offset tool and position 
the cursor over the path. When the (      ) cursor 
appears, click and drag in the direction the offset should 
appear. The offset distance will appear while dragging the 
offset. The distance will be a scaled value using the scale set 
in the CADscale panel, and the units set in the CADtracker 
panel. Click once on a path without dragging to access the 
numeric input dialog box to numerically 
create the offset in scale. 

To see offset distance while dragging,
check Show geometry while dragging in 
the CADtracker panel. Some shapes will 
not be able to offset beyond a certain distance 
without distortion.

Type must be outlined inside of Adobe Illustrator and the 
compound paths must be released prior to using the Offset 
tool. Select the text, choose Type > Create Outlines, then 
Object > Compound Path > Release.

Offset distance cannot be calculated under 5 pts 
(.07 in at 1:1 scale).

tangent line

perpendicular line

offset line
offset object

.25 cm
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CAD wall tools

CADwalls tool group:

Add Wall - Click and drag on the side or end of a wall to 
create a new wall. Click once on the document to input values 
numerically.
Remove Wall - Click a wall that is free of dependent walls to 
remove it.
Move Wall - Click and drag a wall to adjust its location. 
Door Insertion - Click on a wall to insert a door. Define 
the options for width, angle and style.
Window Insertion - Click on a wall to insert a window. 
Define the options for width, walls, framing and style.

CAD wall tools

Add Wall
The Add Wall tool works like the CAD Line tool, 
creating rectangles (representing walls) with a thickness 
defined in the numeric input dialog box of the CADwalls 
panel. Before drawing walls, open the CADwalls panel 
and set the wall thickness and measurement reference. 
Enter any unit value or use the default units defined in 
the Numeric input section of the CADunits panel. 

release mouse button, 
click endpoint, then drag

first click 
and drag

to add a new section,
click the side of the wall
and drag out or click
once to create the wall
section numerically

CADwalls cannot create complete 
enclosures, so be sure to leave 
openings while drawing spaces

to create a corner on a 
wall, click on the end of 
the wall (not the corner 
points) and drag to 
either side
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CAD wall tools (cont.)

If Measure walls to the inside is selected, additional 
wall segments will be joined like this:

If Measure walls to the middle is selected, additional 
wall segments will be joined like this:

If Measure walls to the outside is selected, addition-
al wall segments will be joined like this:

Click and drag on the document to create a wall, or 
click once to access the numeric input dialog box to 
numerically create a wall. 

CAD wall tools (cont.)

Add Wall (cont.)
To draw a wall, select the Add Wall tool and position 
the cursor at the end of the desired wall. Click and drag 
to position the wall. Release the mouse button to create it. 
Hold down the shift key while dragging to constrain the wall 
to 45° increments. Hold down the alt/option key while 
dragging to snap the wall to the nearest unit increment.

To view wall measurements while dragging, make sure that 
Show geometry while dragging is checked in the CADtracker 
panel.

To create an additional wall joined to the end or side of an 
existing wall, position the cursor over the wall path at the 
desired location until the (      ) cursor appears. Then click 
on the path of the wall and begin dragging. Release the 
mouse button to complete the new wall addition. Walls 
can only be added when this cursor appears, indicating an 
underyling wall line. 

The Add Wall tool does not create curved walls, but the 
CADtools Offset tool can simulate curved walls.

Remove Wall
To remove a wall, select the Remove Wall tools and 
position the cursor over the path of the wall to remove. 
When the (      ) cursor appears, click to remove the wall 
extension. Note: Walls can only be removed if they are not 
joined to any dependent wall sections.

Hot Tip!
To obtain the area of a space inside walls, use the CAD Rectangle 
or CADline tool to create a closed shape over the area. Be sure 
to lock the underlying artwork before using the CADline to avoid 
connecting paths. View the area in the CADtracker panel.
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CAD wall tools (cont.)

Move Wall
To move a dependent wall along a primary wall, 
select the Move Wall tool and position the cursor 
over the wall to adjust. Click and drag to slide 
the wall along the primary wall to the desired 
location. 

To view distances between walls while dragging, 
make sure that Show geometry while dragging in is 
checked in the CADtracker panel. Then, while 
moving the wall, dimensions will appear in red 
boxes that indicate measurements between the 
selected wall and other walls along the primary 
wall. The units for these measurements are defined 
at the bottom of the CADtracker panel.

primary wall

dependent wall

In the CADtracker panel, 
check Show geometry 
while dragging to view 
distances between walls 
while dragging.

CAD wall tools (cont.)

Door Insertion
To insert a door into a CADwall, select the Door 
Insertion tool and position the cursor over the line 
of a wall drawn with the Add Wall tool. Click and drag 
to position the door along the wall, or click once at the 
desired door edge. A dialog will appear prompting the 
setting of width, angle and style:

A door will be created independently of the CADwall 
with grouped lines and objects that can be edited with 
Illustrator's selection tools. To delete the door, simply 
select it and click the delete button.

If prompted that there is not enough space 
available for the door, try the following steps:

1. If click-dragging on the wall to position the door, drag 
along with wall until the door preview appears. If this is 
difficult, drag along the other side of the wall to see the 
preview. The door cannot be inserted until there 
is enough space for it to swing open. 

2. Check the thickness of the CADwall. The thickness 
of walls is set in the CADwalls panel under Window > 
CADtools > Show CADwalls. If the thickness (in scale) is 
too small for the width of the door, it cannot be created.

3. Click once on the CADwall line to view the Door 
Insertion Settings. Make sure the door width setting is 
reasonable for the size of the wall.
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CAD wall tools (cont.)

Window Insertion
To insert a window into a CADwall, select the Window 
Insertion tool and position the cursor over the line of 
a wall drawn with the Add Wall tool. Click and drag to 
position the window along the wall, or click once at the 
desired window edge. A dialog will appear prompting the 
setting of width, walls, framing and style:

A window will be created independently of the CADwall 
with grouped lines and objects that can be edited with 
Illustrator's selection tools. To delete the window, simply 
select it and click the delete button.

If prompted that there is not enough space available for 
the window, try the following steps:

1. Check the thickness of the CADwall. The thickness 
of walls is set in the CADwalls panel under Window > 
CADtools > Show CADwalls. If the thickness (in scale) is 
too small for the width of the window, it cannot be 
created.

2. Click once on the CADwall line to view the Window 
Insertion Settings. Make sure the window width setting is 
reasonable for the size of the wall.

Dimensioning control: CADdimensions
Before dimensioning objects, open the CADdimensions panel to 
define attributes for CADtools dimensions. To change the attri-
butes of attached dimensions after they are created, select them 
and make changes in this panel. 

Edit the value of any dimension with the Illustrator Type 
tool and it will retain the edited value as custom text.  

Under the General section, choose 
Format and color for dimensions:

• Measurement is the most common 
dimension format and determines 
numeric value of object lines and 
distances between points. With 
Measurement selected, choose units 
and precision in the panel below.

• ABC Incremental creates text 
dimensions that automatically 
increment alphabetically. To force 
the next letter, enter the desired 
value in the Next field. Use the 
Settings button to select options.

• 123 Incremental creates text 
dimensions that automatically 
increment numerically. To force 
the next number, enter the desired 
value in the Next field. Use the 
Settings button to select options.

• Custom text creates dimensions 
that can be edited text or number 
values. Use the Settings button to 
select options.
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Dimensioning control: CADdimensions (cont.)

Use the Settings button in the CADdimensions panel to control 
the behavior of each type of format excluding measurement. 
Use the Detach button to unlink selected dimensions from their 
associated paths and objects. Dimensions are attached to objects 
if Attach dimensions/labels is selected under Window > 
CADtools > Preferences...

General:
• Change the dimension text and line 
color with the color picker. 

• Use the Detach button to unlink 
dimensions from their associated 
objects. First select the dimension 
and then click the Detach button. 
If a dimension was not created over 
a point or path, this feature will 
not perform any action. Detached 
dimensions can no longer be edited 
with CADtools panels but can be 
edited with Illustrator's tools.

Dimensioning control: CADdimensions (cont.)

Terminators: 
• Select from several terminator types 
and adjust stroke weight, length, and 
angle of arrowhead with field values.

• Choose if the terminators will point 
inside, outside, or the best interpreted 
side of witness lines

Text: 
• Use the icons to set the location 
of dimension text inline or above line 
for horizontal, vertical, and inclined 
dimensions.

• Enter a value for text distance above 
the dimension line 
(see sample below).

• Adjust the spacing between the 
dimension line and text with the Inline 
spacing slider.

• Check Free sliding text to 
adjust the placement of the 
dimension inside the dimension 
line while dragging (use the control 
key while dragging to snap the dimen-
sion to center).

• Diameter or radius symbols can 
appear before or after dimension text.

• Choose to show axonometric text as 
flat or projected with artwork.

3.53 cm

Appended unit (CADunits panel)

Distance above line

Witness line gap

Witness line extension

Dimension lines snap distance 
(using shift key)

Dimension line

Witness lines

For ABC Incremental
format, select how to increment 
and control the next letter.

For 123 Incremental format, 
choose if numbers will increment 
as all, even, or odd values. Control 
the next number, option for lead-
ing zeroes, and digits. 

For the Custom text format, 
control if text will automatically 
select and display a custom text 
value.
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Dimensioning control: CADdimensions (cont.)

Dimension lines: 
• Dimension line weight and snap 
tolerance are set with field values. 
Snap distance sets the increment 
value when using the shift key to 
snap dimensions away from objects.

Witness lines: 
• Use field values to set witness line 
weight, extension beyond dimension 
line, and gap from object (see sample 
below).

3.53 cm

Appended unit (CADunits panel)

Distance above line

Witness line gap

Witness line extension

Dimension lines snap distance 
(using shift key)

Dimension line

Witness lines

Dimensioning control: CADdimensions (cont.)

Diameter dimensions: 
• Choose to span diameter dimensions 
across the circle or from the circle 
center (see sample above).

• Define a leader line length for 
diameter and radius dimensions.

Chain dimensions: 
• Select chain datum for dimension-
ing segments cumulatively from a 
reference point (datum); JIS termina-
tor complies with Japanese Industrial 
Standards.

2.71 cm

2.71 cm

Leader length

Span circle checked

Span circle unchecked

24
.9

5 
cm

53
.7

7 
cm

88
.2

3 
cm

0.
00

 c
m

JIS terminator
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Automation: CADshortcuts
The CADshortcuts panel easily controls CADtools panel settings 
(except scale) and automatically dimensions objects. Presets are 
automatically saved into a file called "Presets." Mac users can use 
the Finder's Window > Go > Go to Folder... menu and type: 
~/Library/Preferences/Hot Door/CADtools 8/Presets. 
On Windows XP CADpresets is located in C:\Documents and 
Settings\yourusername\Application Data\Hot Door\CADtools 
8\Presets. On Windows 7 and Vista CADpresets is located in C:\
Users\yourusername\AppData\Local\Hot Door\CADtools 8\Pre-
sets. This preset file may be shared with others using CADtools 8.

Automatic dimensions
To apply dimensions to the document or selected artwork, first use 
the checkboxes at the bottom of the CADshortcuts panel to select 
the type of linear or radial dimensions. Select Crosshairs to show 
circle center marks. To apply the settings to all objects in the 
document, select the Document button. To apply settings to all 
selected objects, choose the Selection button.

Auto dimensions:
• Apply dimensions to all objects 
on the document or selected artwork  
by clicking the Document or 
Selection buttons. Choose types 
of dimensions from the linear and 
radial dimension checkboxes. 
Check Crosshairs to add them to 
circle centers.

Presets:
• Define presets for all CADtools 
panel settings. Select and apply a 
preset from the list or create new 
presets with current CADtools panels 
settings. Click Apply to set the 
preset.

Automation: CADshortcuts (cont.)

Defining presets
To define a new CADtools preset, first set up the CADtools panels as 
desired. Click the new preset icon at the bottom of the CADshortcuts 
panel and enter a name for the preset in the dialog box.

Applying presets
To apply an existing preset, select a preset from the scrolling Presets 
list. Choose from Basic Architecture and Basic Engineering presets 
or select a custom preset. Click Apply to set the preset. Notice 
how settings such as terminator appearance, units and precision will 
change inside the CADtools panels. 

Editing presets
To rename or delete a preset, first set up the CADtools panels as 
desired. Then select an existing preset name in the scrolling list and 
click the edit button at the bottom of the CADshortcuts panel. Re-
name the preset, click OK, and then click Apply to set the preset.
To delete a preset, select an existing preset name in the scrolling list 
and click the delete button at the bottom of the CADshortcuts panel.

R 0.361"

1.38
0

"

1.708"

3.472"

4.478"

• Edit, new preset and delete buttons 
help define presets in the list. Presets 
are saved into a CADpresets file.
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2D dimensioning tools

Horizontal Dimension (by Line) - Click and drag out any horizontal 
segment to dimension the distance between two anchor points.
Horizontal Dimension (by Points) - Click multiple points anywhere on 
the document and drag to dimension their horizontal distances.
Horizontal Datum Dimension - Click a point of origin, then click 
multiple points and drag to dimension the horizontal distances from the 
origin.
Horizontal Chain Datum Dimension - Click a point of origin, then 
click multiple points and drag to dimension the distance in chain style 
Vertical Dimension (by Line) - Click and drag any vertical segment to 
dimension the vertical distance between two anchor points. 
Vertical Dimension (by Points) - Click multiple points anywhere on the 
document and drag to dimension their vertical distances.
Vertical Datum Dimension - Click a point of origin, then click multiple 
points and drag to dimension their vertical distances from the origin.
Vertical Chain Datum Dimension - Click a point of origin, then click 
multiple points and drag to dimension the vertical distance in chain 
style.
Inclined Dimension (by Line) - Click and drag any inclined segment to 
dimension the inclined distance between two anchor points.
Inclined Dimension (by Points) - Click multiple points anywhere on 
the document and drag to dimension their inclined distances.
Inclined Datum Dimension - Click a point of origin, then click multiple 
points and drag to dimension their inclined distances from the origin.
Inclined Chain Datum Dimension - Click a point of origin, then click 
multiple points and drag to dimension their inclined distances from the 
origin in chain style.
Angle Dimension - Click a line of origin, then click and drag a 
nonparallel line to dimension the angle between the lines.
Arc Length Dimension - Click a point of origin on a circular arc, then 
click and drag another point on the same arc to dimension the length 
along the arc between the points.
Diameter Dimension - Click and drag a point on a circle to dimension 
its diameter.
Radius Dimension - Click and drag a point on a circle to dimension its 
radius.
Fillet Radius Dimension - Click and drag directly over an arc or fillet to 
display the radius of the arc or fillet at the cursor location.
Bézier Curvature Dimension - Click and drag directly over a curved line 
to display the radius of the curve at the cursor location.
Tangent Dimension - Click and drag directly over a curved line 
to display the tangent of the curve at the cursor location. Use alt/option 
key to display the normal/perpendicular line. Use shift to diplay the 
normal and tangent lines. Use control to toggle normal placement.
Center line - Click and drag to create the line.
Object center - Click within an object to mark the center of its 
bounding box.

2D dimensioning tools (cont.)

Horizontal Dimension (by Line)
The Horizontal Dimension (by Line) tool will 
dimension horizontal line segments. A line 
segment is a path between two anchor points 
in Illustrator. 

Select the Horizontal Dimension (by Line) tool 
and position the cursor over the line to dimension. 
When the (      ) cursor appears, click the horizontal 
line and drag to position the dimension line. Hold 
down the shift key while dragging to offset the hori-
zontal dimension line in increments. The offset incre-
ment value is set in the Snap distance field in the 
Dimension lines section of the CADdimensions panel.

Note: To quickly toggle between Horizontal Dimension 
(by Line) and Vertical Dimension (by Line), use the 
alt/option key.

Horizontal Dimension (by Points)
The Horizontal Dimension (by Points) tool will dimen-
sion the horizontal distance between multiple points. 
Define the location of these points anywhere on the 
document.

Select the Horizontal Dimension (by Points) tool 
and position the cursor at one end of the horizontal 
distance to dimension. If this is an anchor point, the 
cursor will change to (      ) . Then click the mouse 
button once and release the mouse button. Position 
the cursor at the next point along the horizontal 
distance to dimension. Continue clicking on points 
along the horizontal distance until the last point is 
clicked, then drag to position the dimension line. Use 
the shift key while dragging to place the dimension 
line at a set distance from the object. The offset in-
crement value is set in the Snap distance field in the 
Dimension lines section of the CADdimensions panel.

Note about changing tools: To quickly toggle 
between Horizontal Dimension (by Points) and 
Vertical Dimension (by Points), use the alt/option key.

click once
on a line 
segment
and drag

click on 
multiple
points and 
drag

click on corner 
points, not 
lines, when 
dimensioning 
by points
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2D dimensioning tools (cont.)

Horizontal Datum Dimension
The Horizontal Datum Dimension tool will dimension 
the horizontal distances between a point of origin 
and other points. Define the location of these points 
anywhere on the document.

Select the Horizontal Datum Dimension tool 
and position the cursor at the origin on one 
end of the horizontal distance to dimension. If this is 
an anchor point, the cursor will change to (      ) . Then 
click the mouse button once and release the mouse 
button. Position the cursor at the next point along the 
horizontal distance to dimension. Continue clicking on 
points along the horizontal distance until the last point 
is clicked, then drag to position the dimension line. Use 
the shift key while dragging to place the dimension line 
at a set distance from the object. The offset increment 
value is set in the Snap distance field in the Dimension 
lines section of the CADdimensions panel.

Horizontal Chain Datum Dimension
The Horizontal Chain Datum Dimension tool will make 
a datum dimension line appear as a linear chain of 
dimensions rather than stacked dimensions. Follow the 
instructions for Horizontal Datum Dimension.

To change the datum dimension terminator to a JIS 
terminator, check JIS terminator in the CADdimensions 
panel. 

Note about changing tools: To quickly toggle between 
Horizontal Datum Dimension and Vertical Datum Dimen-
sion tools, use the alt/option key.

click on a 
point of 
origin

click
multiple
points and 
drag

origin

chain datum with JIS terminator

2D dimensioning tools (cont.)

Vertical Dimension (by Line)
The Vertical Dimension (by Line) tool will dimen-
sion vertical line segments. A line segment is a path 
between two anchor points in Illustrator. 

Select the Vertical Dimension (by Line) tool and po-
sition the cursor over the line to dimension. When 
the (      ) cursor appears, click the vertical line 
and drag to position the dimension line. Hold down 
the shift key while dragging to offset the vertical 
dimension line in increments. The offset increment 
value is set in the Snap distance field in the Dimen-
sion lines section of the CADdimensions panel.

Note about changing tools: To quickly toggle 
between Vertical Dimension (by Line) and Horizontal 
Dimension (by Line), use the alt/option key.

Vertical Dimension (by Points)
The Vertical Dimension (by Points) tool will 
dimension the vertical distance between multiple 
points. Define the location of these points 
anywhere on the document.

Select the Vertical Dimension (by Points) tool and 
position the cursor at one end of the vertical dis-
tance to dimension. If this is an anchor point, the 
cursor will change to (      ) . Then click the mouse 
button once and release the mouse button. Posi-
tion the cursor at the next point along the vertical 
distance to dimension. Continue clicking on points 
along the vertical distance until the last point is 
clicked, then drag to position the dimension line. 
Use the shift key while dragging to place the dimen-
sion line at a set distance from the object. The 
offset increment value is set in the Snap distance 
field in the Dimension lines section of the CADdi-
mensions panel.

Note about changing tools: To quickly toggle be-
tween Vertical Dimension (by Points) and Horizontal 
Dimension (by Points), use the alt/option key.

click once
on a line 
segment
and drag

click on 
multiple
points and 
drag
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click on a 
point of origin

click
multiple
points and 
drag

2D dimensioning tools (cont.)

Vertical Datum Dimension
The Vertical Datum Dimension tool will dimension the 
vertical distances between a point of origin 
and other points. Define the location of 
these points anywhere on the document.

Select the Vertical Datum Dimension tool and 
position the cursor at the origin on one end of 
the vertical distance to dimension. If this is an anchor 
point, the cursor will change to (      ). Then click 
the mouse button once and release the mouse but-
ton. Position the cursor at the next point along the 
vertical distance to dimension. Continue clicking on 
points along the vertical distance until the last point 
is clicked, then drag to position the dimension line.  
Use the shift key while dragging to place the dimen-
sion line at a set distance from the object. The offset 
increment value is set in the Snap distance field in the 
Dimension lines panel of the CADdimensions panel.

Note about changing tools: To quickly 
toggle between Horizontal Datum Dimension 
and Vertical Datum Dimension tools, use 
the alt/option key.

Vertical Chain Datum Dimension
The Vertical Chain Datum Dimension tool 
will make a datum dimension line appear 
as a linear chain of dimensions rather than 
stacked dimensions. Follow the instructions 
for Vertical Datum Dimension.

To change the datum dimension terminator
to a JIS terminator, check JIS terminator 
in the CADdimensions panel. 

Note about changing tools: To quickly 
toggle between Vertical Chain Datum 
Dimension and Horizontal Chain Datum 
Dimension tools, use the alt/option key.

origin

2D dimensioning tools (cont.)

Inclined Dimension (by Line)
The Inclined Dimension (by Line) tool will 
dimension angled or “inclined” line segments. 
A line segment is a path between two anchor 
points in Illustrator. 
 
Select the Inclined Dimension (by Line) tool 
and position the cursor over the inclined line to 
dimension. When the (      ) cursor appears, click 
the line and drag to position the dimension line. 
Use the shift key while dragging to place the 
dimension line at a set distance from the object. 
The offset increment value is set in the Snap 
distance field in the Dimension lines section of 
the CADdimensions panel.

Inclined Dimension (by Points)
The Inclined Dimension (by Points) tool will 
dimension the inclined, absolute distance 
between multiple points along any axis. Define 
the location of these points anywhere on the 
document.

Select the Inclined Dimension (by Points) tool 
and position the cursor at one end of the in-
clined distance to dimension. If this is an anchor 
point, the cursor will change to (       ). Then 
click the mouse button once and release the 
mouse button. Position the cursor at the oppo-
site end of the inclined distance to dimension. 
If this is an anchor point, the cursor will change 
to (      ). Then click and drag to position the 
dimension line. Use the shift key while dragging 
to place the dimension line at a set distance 
from the object. The offset increment value is set 
in the Snap distance field in the Dimension lines 
section of the CADdimensions panel.

Note about dimensioning on inclines: 
To prevent errors in measuring nonlinear inclined 
segments, the inclined chain dimension tool will 
only measure multiple segments contained within 
a reasonable angle. 

click once
on a line segment
and drag

click on multiple
points and drag
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click on a 
point of origin

click
multiple
points and 
drag

origin

2D dimensioning tools (cont.)

Inclined Datum Dimension
The Inclined Datum Dimension tool will 
dimension the inclined distances between 
a point of origin and other points. Define 
the location of these points anywhere on 
the document.

Select the Inclined Datum Dimension tool and 
position the cursor at the origin on one end of 
the inclined distance to dimension. If this is an 
anchor point, the cursor will change to (      ). 
Then click the mouse button once and release the 
mouse button. Position the cursor at the next point 
along the inclined distance to dimension. Continue 
clicking on points along the inclined distance until 
the last point is clicked, then drag to position the 
dimension line. Use the shift key while dragging to 
place the dimension line at a set distance from the 
object. The offset increment value is set in the Snap 
distance field in the Dimension lines section of the 
CADdimensions panel.

Inclined Chain Datum Dimension
The Inclined Chain Datum Dimension tool 
will make a datum dimension line appear 
as an inclined chain of dimensions rather than 
stacked dimensions. 

To change the datum dimension terminator 
to a JIS terminator, check JIS terminator 
in the CADdimensions panel. 

2D dimensioning tools (cont.)

Angle Dimension
The Angle Dimension tool will dimension the angle 
between any two nonparallel lines. Position the 
cursor over the first line. When the (      ) cursor 
appears, click anywhere on the line and release 
the mouse button. Then position the cursor over 
the second line. When the (      ) cursor appears, 
click anywhere on the line and drag to position 
the angle dimension line. Hold down the control 
key while dragging to dimension the opposite 
angle. Hold down the alt/option key while drag-
ging to remove witness lines.

Arc Length Dimension
The Arc Length Dimension tool will dimension the 
length of a circular arc or circle defined by any 
two points on the circular arc or circle. Position 
the cursor over the arc or circle where the arc 
length dimension will begin. When the (      ) or 
(      ) cursor appears, click once on the arc or cir-
cle. Then position the cursor over the arc or circle 
where the arc length dimension will end. When 
the (      ) or  (      ) cursor appears, click on the 
arc and drag to position the arc length dimension 
line. Hold down the control key while dragging to 
dimension the opposite arc length.

Note about dimensioning lengths along curves: 
The Arc Length Dimension tool works only on 
circular arcs or circles. To retrieve the length 
between two points along a Bezier curve, copy the 
segment with the direct selection tool, paste, and 
use the CADtracker panel to view the length of the 
Bezier segment in scale. If necessary, use the 
Illustrator Add Anchor Point tool to add points 
along the Bézier curve for measuring.

click on 
second line
and drag

click on 
first line

click on first 
point along 
a circle

click on 
second point
and drag
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2D dimensioning tools (cont.)

Diameter Dimension
Select the Diameter Dimension tool and position 
the cursor over the path of a circle. When the 
(      )  cursor appears, click and drag to position 
the diameter dimension. Hold down the shift key 
while dragging to constrain the tool to multiples 
of 45°. Hold down the control key while dragging 
to toggle the placement of the diameter dimension 
text.

Note about changing tools: To quickly toggle 
between radius dimension and diameter dimension, 
use the alt/option key.

Radius Dimension
Select the Radius Dimension tool and position the 
cursor over the path of a circle. When the (      )  
cursor appears, click and drag to position the radius 
dimension. Hold down the shift key while dragging 
to constrain the tool to multiples of 45°. Hold 
down the control key while dragging to toggle the 
placement of the radius dimension text.

Fillet Radius Dimension
Click and drag directly over an arc or fillet to 
display the radius of the arc or fillet at the cursor 
location. When the (      )  cursor appears, click 
and drag to position the fillet radius dimension. 
Hold down the alt/option key while dragging to 
constrain the tool to the center of the radius. 
Hold down the control key while dragging to 
toggle the placement of the fillet radius 
dimension text.

click on the 
circle path
and drag

click on the 
circle path
and drag

1.00 cm

1.00 cm

Hot Tip!
Letters can be more accurately dimensioned after 
converting the text to outlines, so that cursors 
can snap to segment points and paths while 
dimensioning. 

click and drag 
directly over the 
curved path

click and drag 
directly over the 
curved path

112°

32°

2D dimensioning tools (cont.)

Bézier Curvature Dimension
The Bézier Curvature Dimension tool will auto-
matically display the radius at any point on a 
Bézier curve. Select the Bézier Curvature Dimen-
sion tool and position the cursor directly over 
a Bézier curve. When the (      ) cursor appears, 
click and drag along the Bézier curve. While 
dragging along the curved path, view a radius 
and its arc at every point. To create the Bézier 
curvature dimension at any point, release the 
mouse button at that point. To hide the arc, hold 
down the control key while dragging.

Note about the tool limitations: Circles and arcs 
created within Illustrator are constructed with 
Bézier curves. The approximation of their radius 
may reveal up to 5% difference in value using the 
Bézier Curvature Dimension tool. 

Tangent Dimension
The Tangent Dimension tool will automatically 
display the tangent line and its angle at any 
point along a Bézier curve. Select the Tangent 
Dimension tool and position the cursor directly 
over a Bézier curve. When the (      ) cursor 
appears, click and drag along the Bézier curve. 
While dragging along the curved path, view 
a tangent line at every point. To create the 
tangent line, release the mouse button at that 
point. Use alt/option key to display the 
tangent's normal and its angle. Use control 
to toggle normal placement on either side of the 
path.
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2D dimensioning tools (cont.)

Center Line
The Center Line tool creates a center line on the 
document. Select the Center Line tool and click and 
drag to position the line, releasing the mouse button 
to create the line. Hold down the shift key while 
dragging to constrain the tool to multiples of 45°.

Hot Tip!
To place a center line over a shape, first click the 
object with the object center tool. Then select the 
center line tool and drag over one of the circle 
center lines.

Object Center
Select the Object Center tool and position the cursor 
over the path of an object. When the (     )  cursor 
appears, click once and release the mouse button. 
Hold down the alt/option key while clicking to 
create a smaller object center mark. 

Use the object center tool to find the center of 
any shape or path. The center is determined by 
the invisible bounding box enclosing the artwork.

To apply object centers to text, create outlines 
before applying the Object Center tool.

Note on center lines and object centers:
To place a dimension or label on a center line or 
object center, first ungroup it.  

click and
drag

click on an 
object path

with the 
alt/option key

Labeling: CADlabels panel
The CADlabels panel sets the behavior and appearance of the 
Label, Multiple Leader Label, Datum Feature, Datum Target and 
Section Line tools. Choose Window > CADtools > Show 
CADlabels. 

Icons show the label line and border style, with leader length 
and border options. Shape borders can also stretch to fit 
custom text. Remember to check Attach dimensions/labels 
under Window > CADtools > Preferences... to create CADtools 
labels that can later be modified in appearance.

 

General section:

• ABC Incremental creates text 
labels that automatically 
increment alphabetically. To force 
the next letter, enter the desired 
value in the Next field. Use the 
Settings button to select options.

• 123 Incremental creates text 
labels that automatically 
increment numerically. To force 
the next number, enter the desired 
value in the Next field. Use the 
Settings button to select options.

• Custom text creates labels that 
can be edited with custom text or 
number values. Use the Settings 
button to select options.

• Geometry displays object ge-
ometry in the label. X and Y show 
location relative to the document 
ruler, width and height refer to the 
size of the object, length/perimeter 
shows distance along path or around 
object, and area is total enclosed 
area.

• Change the dimension text and 
line color with the color picker.

Use the Detach button to unlink 
dimensions from their associated 
objects. If a dimension was not 
created over a point or path, this 
feature will not perform any action. 
Detached labels can be edited with 
Illustrator's tools.
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Labeling: CADlabels panel (cont.)

leader extension

border 
tightness

• Change the label text and line 
color with the color picker. 

• Use the Detach button to unlink 
labels from their associated objects. 
If a label was not created over a 
point or path, this feature will not 
perform any action. Detached labels 
can be edited with Illutrator's tools.

Labeling: CADlabels panel (cont.)

Use the Settings button in the CADlabels panel to control 
the behavior of each type of format. Use the Detach button 
to unlink selected labels from their associated paths and objects. 
Labels are attached to objects only if Attach dimensions/labels 
is selected under Window > CADtools > Preferences...

For ABC Incremental label
format, select how to increment 
and control the next letter.

For 123 Incremental label format, 
choose if numbers will increment 
as all, even or odd values. Control 
the next number, option for lead-
ing zeroes and digits. 

For the Custom text label format, 
control if text will automatically 
select and display a custom text 
value.

For Geometry, choose how object 
geometry will appear in the label. 
X and Y show location relative to 
the document ruler; width and 
height refer to the size of the 
object; length/perimeter shows 
distance along path or around 
object; and area is total enclosed 
area.

 

• Under the Terminators section, 
select from several terminator types 
and adjust weight, length and angle 
of arrowhead with field values.

• In the Text section, customize the 
appearance and size of label text. 

• Under Leaders, set the label leader 
shape and the length of its extension.

• In Shapes, set label border shape 
and the tightness of the border.

• Check Stretch to fit to 
automatically resize label borders to 
fit around custom text or numbers.

• Under Section lines, choose to 
double the weight or add 
the prime symbol to Section lines 
(found in the Labeling tool group).

Text
stretched shape to fit

Text
not stretched to fit

To create labels that will follow attached artwork, check Attach 
dimensions/labels under Window > CADtools > Preferences...
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An invisible linking 
point at the base 
of each attached 
label determines the 
label location when 
updated

A

Labeling: Tools

Label tool - Click and drag to create a label using the format 
settings in the CADlabels panel – ABC incremental, 123 
incremental, Geometry or Custom text. If Custom text is 
selected, labels will be drawn with custom, pre-selected text. 
Multiple leader label - Click multiple points and then drag to 
create the label.
Datum feature - Click and drag to create the label.
Datum target - Click and drag to create the label.
Datum flag - Click and drag to create the label.
Revision bubble - Click an object line, or click and drag to 
create the label. 
Section line - Click and drag to create the line. Use the 
CADlabels panel to make the section line double weight and 
appear with the prime symbol.

Note on attached labels:
If Attach dimensions/labels is checked under Window > 
CADtools > Preferences... labels will attach to a clicked path 
or object. To adjust the angle or extension of a label while 
maintaining attachment, use the CADtools Dimension Redo tool. 
To detach a label, select the label and click the Detach 
button in the CADdimensions panel. Selected labels can 
also be detached by ungrouping them OR unchecking Attach 
dimensions/labels to objects under Window > CADtools > 
Preferences... Detached labels can be edited with 
Illustrator's tools.

A Label or Revision 
bubble placed on 
an object will be 
linked to that 
object and update 
when moved if 
Attach dimensions/
labels is checked in 
Window > CADtools 
> Preferences... 

A

A

Labeling: Tools

Label tool
The CADlabels tool draws labels according to settings in 
the CADlabels panel. Four different formats create labels 
which can increment alphabetically or numerically, 
generate object geometry information or display custom 
text. To change the value of incremental labels, change 
the format to Custom text or edit the label text with 
Illustrator's Type tool. Text changes will be saved with 
the label.

Use the Dimension Redo tool to select and adjust the 
angle of the label without moving its attached point. 

 
Format: ABC Incremental - If ABC Incremental is 
selected in the CADlabels Format menu, the Label tool 
will create character labels that automatically increment 
according to the text settings in the CADlabels panel. 
To create an incremental label, first use the CADlabels 
panel to set the appearance of the label line, label 
shape, and border tightness. Then select the Label tool 
and position the cursor at the base of the desired label. 
Click and drag to position the incremental label. Hold 
down the shift key while dragging to constrain the tool 
to multiples of 45°. Hold down the control key while 
dragging to toggle the placement of the label text.

A click and drag and the letter 
or number will increment according 
to Settings in the CADlabels panel

• Use the After Z 
menu to change 
how alphabet labels 
will change in value 
after Z.

• Set the value of the 
next alphabet label in 
the Next field.
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Labeling: Tools (cont.)

Format: 123 Incremental - If 123 Incremental is selected in 
the CADlabels Format menu, the Label tool will create numeric 
labels that automatically increment according to the text set-
tings in the CADlabels panel. To create an incremental label, 
first use the CADlabels panel to set the appearance of the label 
line, label shape, and border tightness. Then select the Label 
tool and position the cursor at the base of the desired label. 
Click and drag to position the incremental label. Hold down the 
shift key while dragging to constrain the tool to multiples of 
45°. Hold down the control key while dragging to toggle the 
placement of the label text.

• Use the Numbers menu 
to determine if incremental 
number labels will show all, 
even or odd values.

• Set the value of the next 
number label in the Next 
field.

2 click and drag and the number will 
increment according to Settings in the 
CADlabels panel

Labeling: Tools (cont.)

Format: Custom text - If Custom text is selected in the CADlabels 
Format menu, the Label tool will create a text label with a 
definable default value. To create a custom text label, first use 
the CADlabels panel to set the appearance of the label line, 
label shape and border tightness. Select Stretch shapes to fit to 
automatically resize label borders around custom text. Choosing 
Select text will allow quick editing, and the current tool 
will switch to the Type tool. To create multiple labels with the 
same custom text value, enter a text value in the Text field. 
 
Then select the Label tool and position the cursor where the label 
terminator will end. Click and drag to position the custom text 
label. Hold down the shift key while dragging to constrain the tool 
to multiples of 45°. Hold down the control key while dragging to 
toggle the placement of the label text.

Use the Dimension Redo tool to select and adjust the angle of 
the label without moving its attached point. 

• Use the Select menu to 
determine if the default 
text will be selected or not 
selected after the label is 
created.
• Enter text in the Text field 
to create labels with the 
same custom text value.

Custom
stretched shape to fit
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Labeling: Tools (cont.)

Multiple Leader Label
To create a multiple leader label, first use the Format 
menu in the CADlabels panel to set the incremental or 
custom text format. Use the Settings inside the CADlabels 
panel to set the unique letter or number of the next label. 

Then select the Multiple Leader Label tool and position 
the cursor at the base of the desired label. Click multiple 
points and then drag to position the label. Hold down the 
shift key while dragging to constrain the tool to multiples 
of 45°. Hold down the control key while dragging to 
toggle the placement of the label text.

Use the Dimension Redo tool
to select and adjust the angle
of the label without moving 
its attached point. 

Datum Feature
To create a datum feature, first use the Settings button 
in the CADlabels panel to set the letter of the next datum 
feature. Then select the Datum Feature tool and position 
the cursor at the base of the datum feature. Click and 
drag to position the datum feature. Hold down the shift 
key while dragging to constrain the tool to multiples of 
45°. Hold down the control key while dragging to toggle 
the placement of the label text.

Use the CADtools Dimension Redo tool to select and 
adjust the label. 

Datum Target
To create a datum target, select the Datum Target tool and 
position the cursor at the base of the datum target. Click 
and drag to position the datum target. Hold down the 
shift key while dragging to constrain the tool to multiples 
of 45°. Hold down the control key while dragging to 
toggle the placement of the label text. The datum target 
will always be created with “1” and “A” text. To adjust 
the angle of the label while maintaining the link to its 
artwork, use the CADtools Dimension Redo tool to select 
and adjust the label. To change the text, use the Illustra-
tor text tool to select and edit the type. 

1

1
A

Width: 0.500"
Perimeter: 2.000"
Area: 0.250" sq

Using CADtracker Geometry values
and units as defined in the Panels 
section of the CADunits panel. 
To set Panel units, uncheck 
Follow primary dimension units 
in CADunits.

X: Horizontal distance of top left 
corner of object from ruler origin

Y: Vertical distance of top left corner 
of object from ruler origin

Width: Horizontal width of artwork 

Height: Vertical height of artwork

Length: Total distance along path(s)

Perimeter: Total distance around 
closed path(s)

Area: Total area inside closed path(s) 
or inside compound path(s). 

Area calculations will not be accurate 
for compound paths which overlap or 
compound paths which are projected 
in axonometric view.

Labeling: Tools (cont.)

Format: Geometry - If Geometry is selected in the CADlabels 
Format menu, the geometric attributes of an underlying path 
or object are displayed. To create a geometry label, first use the 
CADlabels panel to set the appearance of the label line, label 
shape, and border tightness. X and Y show location relative to the 
document ruler; width and height refer to the size of the object; 
length/perimeter shows distance along path or around object; and 
area is total enclosed area. Then select the Label tool and position 
the cursor directly over the object or path line. When the (      ) 
cursor appears, click and drag to position the geometry label. Hold 
down the shift key while dragging to constrain the tool to mul-
tiples of 45°. Hold down the control key while dragging to toggle 
the placement of the label text.

ABC

click points
then drag

A
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Labeling: Tools (cont.)

Datum Flag
To create a datum flag, first use the CADlabels panel 
to set the Format and Settings for the letter or num-
ber of the next datum flag. Then select the Datum 
Flag tool and click and drag to position the datum 
feature. Hold down the shift key while dragging to 
constrain the tool to multiples of 45°. Hold down the 
control key while dragging to toggle the placement 
of the label text. 

Revision Bubble
The Revision Bubble tool automatically encircles 
artwork or drag to make revision bubbles. 

• To automatically encircle objects with a revision 
bubble, select the revision bubble tool and position 
the cursor over artwork or text path. Click once to 
create the bubble. 

• To create a revision bubble, position the cursor at 
the corner of the bubble to appear. Click and drag 
from one edge of the bubble to the opposite edge. 
Hold down the shift key while dragging to create a 
circular revision bubble. Hold down the control or 
alt/option keys to adjust the bubble appearance.

Section Line
To create a section line, first use the CADlabels 
panel to set the Format and Settings for the letter 
or number of the next section line. To automatically 
double the stroke weight of the section line, check 
the Double section weight option in the CADlabels 
panel. To automatically add a prime symbol to the 
section line text, check the Prime section option 
in the CADlabels panel. Select the Section Line tool 
and click and drag to position the line, releasing the 
mouse button to create the line. Hold down the shift 
key while dragging to constrain the tool to multiples 
of 45°. To toggle the direction of the section line 
label, hold down the control key while dragging.

click and drag

click on an object to 
encircle it

A

A
click and
drag

Construction tools

Title block tool - Click or click-drag desired area to 
enter values for creating a custom title block with 
drawing information. 
Table tool - Click or click-drag desired area to enter 
values for a table with specified rows, columns, lines, 
title and text placeholders.

sample title block

sample table

REVISION 11

2

3

4

REVISION 2
REVISION 3
REVISION 4

Title: Clone House
Date: August 1, 2010
Drawn by: Jed I. Master
Page: 37
Scale: 1/4" = 1'

Table Title

Placeholder

Placeholder

Placeholder

Placeholder

Placeholder

Placeholder

Placeholder

Placeholder

Placeholder

Placeholder

click and drag and 
the letter or num-
ber will increment 
according to the 
CADlabels panel

- A -
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Construction tools (cont.)

Title Block
The Title Block tool automatically creates title blocks 
for identifying drawings and revision details. 

To create a title block, select the Title Block tool and 
click once or click-drag the area to place the title 
block. Enter values to set the specific size, or set the 
margin for filling the artboard. Title block position 
sets the text area at the top, right, bottom, or left 
side of the border. Font defines the typeface used in 
the title block.

Enter text values for Drawing Information. Change 
the subjects on the left or add new ones. The text 
will automatically be saved as default values for the 
next title block.

Construction tools (cont.)

Table
The Table tool automatically creates tables, printable 
labels and charts.

To create a table, select the Table tool and click once 
on the document or click-drag the area to place the 
table. Enter values to set the specific size, or set the 
margin for filling the artboard. Select options to 
create a table title and surrounding table border.

Enter text values for Cell Information. Choose to 
show cell lines or rounded corners. Enter values 
for the number of rows and columns, as well as the 
space between cells. The values will be automatically 
saved by default for the next table.
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Precision control with CADtracker
CADtracker helps monitor and edit object information with 
five sections. The units and precision of the values can 
be changed in the Panels section of the CADunits panel.

Geometry
The Geometry section displays width, height, circumference, 
perimeter, area, angle and line length of objects - including 
points and placed images.

 

accurate area inaccurate area

Precision control with CADtracker (cont.)

Transform
CADtracker's Transform section allows an object to be numerically 
resized in scale. 

Select an object or set of objects 
and enter values in the Transform 
panel (enter digits with up to five 
decimal places in text boxes). 

• To change an object’s horizontal 
location, enter a value in the X 
text box. 

• To change an object’s vertical 
location, enter a value in the Y 
text box. 

• To change the width of a 
selection’s bounding box, enter 
a value in the W text box. 

• To change the height of a 
selection’s bounding box, enter 
a value in the H text box. 

• To rotate a selection, enter a new 
angle between 0 and 360 degrees 
in the Angle text box, or choose a 
value from the popup menu.

• To Constrain proportions of the 
transformed object, check Con-
strain.

• To select the reference point for 
the selection, click a handle on the 
square representing the object’s 
bounding box.

Click the Transform button to 
transform the selected objects. 
Click the Copy button to make a 
transformed copy of the artwork.

Using CADtracker Geometry 
while drawing...

X: Horizontal distance of cursor from 
the ruler origin

Y: Vertical distance of cursor from 
the ruler origin

W: Horizontal width of the artwork

H: Vertical height of the artwork

     Angle between the first click 
point and the current mouse location

Length: Distance between the first 
click point and current mouse location

Radius: Radius of circle or arc

Diameter: Diameter of circle

Perimeter: Distance around a path

Circumference: Distance around a circular 
path

Arc Length: Distance around the circular 
arc between two defined endpoints 

Area: Area of rectangles, ellipses and 
arc (show area in acres using CADtracker 
popout menu)

Using CADtracker Geometry 
with artwork selected...

X: Horizontal distance of top left 
corner of object from the ruler origin

Y: Vertical distance of top left corner 
of object from the ruler origin

W: Horizontal width of artwork 

H: Vertical height of artwork

Length: Total distance along path(s)

Perimeter: Total distance around 
closed path(s)

Area: Total area inside closed path(s) 
or inside compound path(s). Area 
calculations will not be accurate for 
compound paths that overlap or 
compound paths that are projected in 
axonometric view: 

6.5 cm
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Precision control with CADtracker (cont.)

Area Transform
The Area Transform panel helps numerically resize an 
object to a specified area value and retain proportions. 

Precision control with CADtracker (cont.)

Move
CADtracker's Move section numerically moves a selected object 
in scale. 

Select the object(s) and 
enter the desired area in
the Area text box. Click 
the Transform button to 
resize artwork. Type must
be outlined prior to 
transformation.

Tranform

Important!
The coordinate system inside Adobe Illustrator uses increasing 
Y values "moving down" the document. Therefore, use a positive 
Y value to move an object "down" and a negative Y value to move 
an object "up" by default.

Use the pop-out menu to show 
area in acres or retain values 
in fields for repetitive actions.

Select points or objects and 
enter options in the Move 
panel (enter digits with up 
to five decimal places in text 
boxes). 

• To move an object along the 
horizontal axis, enter a value 
in the X text box. 

• To move an object along the 
vertical axis, enter a value in 
the Y text box. 

• To move an object a distance 
along a rotated axis, first 
enter a value in the Distance 
text box. Enter a value for the 
rotation of axis in the angle 
text box, or choose a value 
from the popup menu. Click 
the Move button to move the 
selected points or objects.

Click the Move button again to 
continue moving the objects as 
needed. Click the Copy button 
to make a copy of the artwork 
and move it.
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2D CAD editing tools

Dimension Redo - Click and drag a dimension to change the 
distance from the object it measures.
Fillet - Click on a line segment near a corner, then click any-
where on the adjacent segment and enter the fillet radius in 
the dialog box. Use the alt/option key while clicking to create 
additional fillets with the same radius.
Chamfer - Click on a line segment near a corner, then click on 
the adjacent segment and enter the chamfer offsets from the 
corner in the dialog box. Use the alt/option key while clicking 
to create additional chamfers with the same offsets.
Corner Profile - Click on a line segment near a corner, then 
click on the adjacent segment and enter the shape, offsets, and 
notch value in the dialog box. Use the alt/option key while 
clicking to create additional chamfers with the same offsets.
Trim - Click the excess portion of one of two intersecting lines 
to remove it, or click on a line to remove the distance to its 
closest endpoint. Click and drag across a set of lines to trim 
multiple lines simultaneously.
Extend - Click on a line, then click on any line or object which 
can be intersected by an extension of the line to extend it. 
Path Divider - Click on a path, then choose from options in the 
Path Divider dialog box to divide and/or mark the path into 
measured segments with points or crosshairs. 
Measure Scale - Click the first point from which to measure and 
drag to define the scaled distance. In the custom scale dialog 
box that appears, enter a scaled distance that represents the 
actual distance dragged. The document scale will change based 
on this new equation, and the new scale will be added to the 
CADscale Scale popup menu.
Measure Distance - Click any point and drag to another point. 
The distance between the two points will appear on the screen 
in the units defined in the CADunits panel under Primary dimen-
sion settings. 
Proportion - Click on any object, then click on a second object. 
Select resize to width or height or constrain proportions. The 
first object will resize to match the proportions of the second. 
If multiple objects are selected but ungrouped, click on one of 
the objects to define it as the key object; the rest of the selected 
artwork will follow to match the proportions of the second 
clicked object.

Precision control with CADtracker (cont.)

Repeat
The Repeat panel allows precise duplication of selected objects 
in rows and columns with scaled values.

Select an object and enter 
options in the Repeat panel. 

• To duplicate objects on 
a vertical path, enter the 
number of Rows in the Rows 
text box. Use the directional 
arrows to repeat up or down. 

• To create space between 
the rows of duplicated 
objects, enter the actual value 
in the Space text box on the 
right of the Rows text box. 
The artwork will be created 
according to the scale set in 
the CADscale panel.

• To duplicate objects on a 
horizontal path, enter the 
number of Columns in the 
Cols text box. Use the 
directional arrows to repeat 
left or right.

• To create space between 
the columns of duplicated 
objects, enter the actual value 
in the Space text box on the 
right of the Columns text box. 
The artwork will be created 
according to the scale set 
in the CADscale panel.

• Use the Between menu to 
set the spacing between edges 
or centers of the selected 
objects.

Click the Repeat button to 
repeat the selected objects.
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2.90 cm

first 
click 

second 
click 

2D CAD editing tools (cont.)

Dimension Redo
The Dimension Redo tool changes the distance 
between a dimension or label and the attached object 
while maintaining the link. 

Select the Dimension Redo tool and position the 
cursor over the label or dimension line to resize. 
When the (       ) cursor appears, click and drag to 
adjust the dimension. Use the shift key while drag-
ging to place dimension lines at a consistent distance 
from the object. This offset distance is defined in the 
Snap distance field in the Dimension lines section of 
the CADdimensions panel. To detach a dimension from 
the object it measures, select it and click the Detach 
button.

Fillet
The Fillet tool creates a fillet between two 
intersecting lines or a corner. The fillet radius is 
defined by the last value used in the numeric input 
dialog box. Fillets can be created with radii as small 
as 2 pts (.02 in at 1:1 scale).

Select the Fillet tool and position the cursor over one 
of two intersecting lines to fillet. When the (      ) 
cursor appears, click once on the line, then position 
the cursor over the second intersecting line. When the 
(      ) cursor appears, click once on the second line 
to open the numeric input dialog box. Enter the fillet 
radius value to create the radius.

Note for creating multiple fillets: To 
automatically create additional fillets 
with the same radii, use the alt/option 
key while clicking on the adjacent line.

Note for dimensioning: 
Be sure to fillet objects before 
adding dimensions.

second 
click 

chamfer 
offset

first 
click 

2D CAD editing tools (cont.)

Chamfer
The Chamfer tool creates a chamfer between two 
intersecting lines or a corner. The chamfer length 
becomes the distance between the chamfer endpoints 
and the corner or intersection. 

Select the Chamfer tool and position the cursor over 
one of two intersecting lines to chamfer. When the 
(      ) cursor appears, click once on the line, then 
position the cursor over the second intersecting line. 
When the (      ) cursor appears, click once on the sec-
ond line to open the numeric input dialog box. Enter 
the chamfer offset values to create the chamfer.

Note for creating multiple chamfers: To automatically 
create additional chamfers with the same values, use the 
alt/option key while clicking on the adjacent line.

Fillet and
chamfer...

Does not work with:Works with:

1

corner 
point

Bézier 
point

hyperextended 
Bézier curve
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1

2

1

2

1

1
1

2

2 2
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2

1
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2D CAD editing tools (cont.)

Trim
The Trim tool will automatically delete the excess por-
tion of an intersecting path or the distance between 
the click point and the closest endpoint. For inter-
secting paths, select the Trim tool and position the 
cursor over the excess portion of the line. When the 
(      ) cursor appears, click once on the line to remove 
the distance to the intersection. For non-intersecting 
paths, select the Trim tool and click the trim location 
on the path.

To trim multiple lines at once, select the Trim tool and 
click-drag over the excess portions of lines to trim. 
They will trim to the nearest intersecting line or at the 
click-drag point if there is no intersection.

Note about trimming: To create trim points along the 
path without deleting the artwork, double-click the Trim 
tool and set the tool preferences. 

2D CAD editing tools (cont.)

Corner Profile
The Corner Profile tool will transform corners to shapes 
commonly used in the construction industry, including 
basic chamfers and fillets. Corner profiles can be 
created on 90° corners or 90° intersections. 

Select the Corner Profile tool and position the cursor 
over one of two intersecting lines to chamfer. When the 
(      ) cursor appears, click once on the line, then posi-
tion the cursor over the second intersecting line. When 
the (      ) cursor appears, click once on the second line 
to open the numeric input dialog box. Enter the corner 
profile values to create the chamfer.

click once to 
trim the line 
to the nearest 
intersection

click once
to trim the
excess of
a single line

drag over a
set of lines 
to trim their
excess or
portions to
the nearest
intersection

Note for creating multiple chamfers: To automatically create 
additional chamfers with the same values, use the alt/option key 
while clicking on the adjacent line.
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click once on 
the line and 
then on the 
path to extend 

click and drag
the distance 
from which to 
measure

2D CAD editing tools (cont.)

Extend
The Extend tool will automatically extend a path to 
meet another path. Select the Extend tool and 
position the cursor over the path to extend. When 
the (      ) cursor appears, click once on the path, then 
click the path to extend. Note: The two paths must be 
able to intersect.

Path Divider
The Path Divider tool divides a path in sections or in 
specified increments from beginning, middle or end. 
Divisions can be marked with anchor points and cross-
hairs and cut into paths. Select the Path Divider tool and 
click on the path to divide. Use the dialog box to set the 
options for division.

Measure Scale
The Measure Scale tool sets a custom scale based on 
a representative actual distance. Measure Scale works 
much like a legend on a map. Select the Measure Scale 
tool and click the first point from which to measure. 
Drag to define the scaled distance. In the custom scale 
dialog box that appears, enter a scaled distance that 
represents the actual distance dragged. The current 
scale will change based on this new equation, and 
the new custom scale will be added to the Scales list 
in the CADscale panel.

2D CAD editing tools (cont.)

Measure Distance
The Measure Distance tool will display the distance 
between any two points. Select the Measure Distance 
tool and click-drag from one point to another. To select 
a point on an object, make sure that the (      ) or (      ) 
cursor appears when clicking or releasing. The absolute 
scaled distance and scale (based on the first clicked 
object) will appear upon release.

Proportion
For simple control, use the Proportion tool to resize an 
object to another object's width, height or all aspects 
with optional constrained proportions. Select the Pro-
portion tool and click a point on one of the unselected 
objects. Click any point on the second object. In the 
Proportion dialog box, select Resize to width or height. 
If  both are selected, proportions will automatically 
constrain. Click OK and the first object will resize to 
match the proportions of the second. 

click 
and drag
between 
any two 
points

click 
any two 
points of 
separate
objects

click a point on the object or 
grouped objects, then click on 
the object of desired proportion
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2D CAD editing tools (cont.)

For key object control, use the Proportion tool to resize 
objects based on selected grouped or ungrouped objects. 
Ungrouped selected objects follow the clicked key object 
when resizing, and grouped selected objects resize together.

If the selected objects to resize 
are grouped, then the objects 
will resize together to fit the 
proportions of the second object 
as shown.

1. Click grouped set

1. Click one 
key object in 
the selected, 
ungrouped set - the 
"A" as shown

2. Click object to 
match proportion

2. Click object to 
match proportion

If the selected objects to resize 
are ungrouped, then the pro-
portion will resize the objects 
together, fitting only the 
clicked object into the second 
object as shown.

OK

OK

Axonometric drawing: CADaxonometric panel
Axonometric drawing displays objects that are rotated along 
different axes, visualizing real-world details for engineering and 
manufacturing. CADtools allows creation and editing of 
axonometric artwork by projection or drawing. Project flat 
artwork to top, front, or side planes with the CADaxonometric 
panel or draw axonometric artwork with the CADaxonometric 
drawing tools. Both of these methods produce artwork that can 
be dimensioned with CADaxonometric dimensioning tools.

Note: Copy artwork or save a copy of the document before 
projecting artwork to preserve original 2D artwork. 

Setting the view for drawing or projection 
The CADaxonometric panel projects flat artwork in axonometric 
view and controls the appearance of axonometric artwork. Use 
the preset menu to choose from existing views, or create a custom 
view by rotating the cube icon. To create a view numerically, use 
the 2D and 3D angle field values. 

• Start with an axometric cube on the 
document to help define a view.

• Adjust the cube icon until the cube 
appears in the desired view, or choose 
from preset views.

 • Check Foreshorten to shorten 
receding lines to approximate 
realistic views.

Note: CADaxonometric artwork will not update with changes 
in the CADaxonometric panel. 
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projected on 
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projected on 
front/left plane

bottom

front side

top

front side

each view 
projected

each view 
projected

top
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Axonometric drawing: CADaxonometric panel (cont.)

Projecting complex objects 
Select the piece(s) of artwork that comprise one plane and choose 
Object > Group. Select each set of grouped artwork and click the 
corresponding plane on the icon in the CADaxonometric panel. 

Select art separately and project...

or select art together and project

Projecting a three-view layout
If two or three views are drawn for projection, arrange the artwork 
prior as shown below for best results: 

For bottom views:

For top views:

Axonometric drawing: CADaxonometric panel (cont.)

Foreshortening
Some axonometric views appear more realistic when foreshortening is 
applied. For example, in the Trimetric view below, three squares were 
projected with and without foreshortening. Before projecting artwork 
with foreshortening, check the Foreshorten button in the CADaxono-
metric panel. 

Editing axonometric objects
Flatten to edit projections in 2D - To edit projected axonometric 
artwork, select the artwork and click the Flatten button in the CADax-
onometric panel. After making changes, click on the faces of the cube 
icon to re-project the artwork as top, front and side planes.

Axonometric drawing - Easily create axonometric vector artwork 
with CADtools axonometric drawing tools. The cube icon in the 
CADaxonometric panel highlights to indicate the face being drawn. 
The default face is the front/left side. To create a side/right face, 
drag with cmd/cntrl key. To create a top/bottom face, drag with 
alt/option key.
 

Projecting simple objects
To project 2D artwork on 
axonometric planes, first 
draw artwork flat inside 
Adobe Illustrator. Unattached 
dimensions can also be 
projected with the artwork. Select the object and click on a side 
of the cube icon in the CADaxonometric panel to project it on 
that plane.

front/
left

side/
right

top

projected without 
Foreshorten 
checked in 
Trimetric view

projected with 
Foreshorten 
checked in 
Trimetric view
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Axonometric drawing: Tools

Axonometric drawing tool group:
Use the following keys to create front, side or horizontal faces 
with the CADaxonometric drawing tools:

 

Axonometric Rectangle - Click and drag to create the shape 
according to settings in the CADaxonometric panel.
Axonometric Centered Rectangle - Click and drag to create the 
shape from its center.
Axonometric Ellipse - Click and drag to create the shape.
Axonometric Centered Ellipse - Click and drag to create the 
shape from its center.
Axonometric Grid - Click and drag to create a grid based on the 
settings in the CADunits panel.
Axonometric Cube - Click and drag to create the front, side or 
top face (with control/command key for side or alt/option for 
top or bottom). After releasing the mouse, drag perpendicular 
to the side to create depth. When the desired depth is reached, 
click the mouse to finish creating the cube.
Axonometric Cylinder - Click and drag to create the front, side 
or top face (with control/command key for side or alt/option for 
top or bottom). After releasing the mouse, drag perpendicular 
to the side to create depth. When the desired depth is reached, 
click the mouse to finish creating the cylinder.

Front (or left side) vertical faces: No modifier key
Side (right) vertical faces: Hold down the 
command key (Mac) or control key (Windows) 
after beginning to drag with the tool
Top/bottom faces: Hold down the alt/option key 
after beginning to drag with the tool

Axonometric drawing: Tools (cont.)

Axonometric Rectangle 
Select the Axonometric Rectangle tool and position 
the cursor at the corner of the desired rectangle. 
Click and drag from one edge of the rectangle to 
the opposite edge. To draw a front face rectangle, 
click and drag to the opposite edge. To create a 
side face, hold down the command/control key 
after beginning to drag. To create a top or bottom 
face, hold down the alt/option key after beginning 
to drag. (Bottom faces can only be created if the 
axonometric view is rotated so that the bottom 
view is showing.) Hold down the shift key to cre-
ate a square in axonometric view. The cube icon 
in the CADaxonometric panel indicates the face 
being drawn.

To numerically create the rectangle, click once on 
the document. The click point will become the top 
right corner of a front face, the top left corner of a 
side face, and the bottom corner of a top face.

Axonometric Centered Rectangle
This tool works just like the Axonometric 
Rectangle tool, except that the initial click point 
becomes the center of the axonometric rectangle. 
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Axonometric drawing: Tools (cont.)

Axonometric Ellipse 
Select the Axonometric Ellipse tool, click and drag 
from one edge of the ellipse to the opposite edge. 
The cursor is located at the corner of the bounding 
box of the ellipse - not actually on the ellipse path. 
To draw a front face ellipse, click and drag to the 
opposite edge. To create a side face, hold down the 
command/control key after beginning to drag. To 
create a top or bottom face, hold down the alt/op-
tion key after beginning to drag. (Bottom faces can 
only be created if the axonometric view is rotated 
so that the bottom view is showing.) Hold down the 
shift key to create a circle in axonometric view. The 
cube icon in the CADaxonometric panel indicates 
the face being drawn.

Axonometric Centered Ellipse 
This tool works just like the Axonometric Ellipse 
tool, except that the initial click point becomes the 
center of the axonometric ellipse. 

Axonometric drawing: Tools (cont.)

Axonometric Grid 
Select the Axonometric Grid tool and position 
the cursor at the corner of the desired grid. 
Click and drag from one edge of the grid to the 
opposite edge. Hold down the shift key while 
dragging to create a square grid. To reduce 
the grid spacing, use the left bracket key [. To 
increase the grid spacing, use the right bracket 
key ] immediately after the grid is created and 
selected. 

Axonometric Cube 
Select the Axonometric Cube tool and click and 
drag a front, side or top face similar to 
drawing an axonometric rectangle. After 
releasing the mouse, immediately drag 
along the axonometric angle without 
clicking to preview the cube depth. 
When the desired depth is reached, 
click the mouse to create the cube 
according to the current axonometric 
view angle. Cubes are automatically 
grouped when created. 

Single-click on the document to create a cube 
numerically. The cube’s central 'home point' 
will be placed at the click point.

Axonometric Cylinder 
Select the Axonometric Cylinder tool, click 
and drag a front, side, or top face similar to 
drawing an axonometric ellipse. After releas-
ing the mouse, immediately drag along the 
axonometric angle without clicking to preview 
the cylinder’s depth. When the desired depth 
is reached, click the mouse to create it.  The 
exact drag point (top or bottom) differs based 
upon how the cylinder was created. Cylinders 
are automatically grouped when created. 

Single-click on the document to create a 
cylinder numerically. The cylinder face’s center 
point will be placed at the click point.

home point
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Axonometric dimensioning: Tools

Axonometric dimension tool group:
Horizontal Axonometric Dimension (By Line) - 
Click and drag out any horizontal segment projected 
in axonometric view to dimension the distance 
between two anchor points.
Horizontal Axonometric Dimension (By Points) - 
Click multiple horizontal points in axonometric view 
and drag to dimension the distance between two or 
more anchor points.
Horizontal Axonometric Datum Dimension - Click 
a point of origin, then click multiple horizontal 
points in axonometric view and drag to dimension 
the distances from the origin.
Vertical Axonometric Dimension (By Line) - Click 
and drag out any vertical segment projected in 
axonometric view to dimension the distance between 
two anchor points.
Vertical Axonometric Dimension (By Points) - 
Click multiple vertical points in axonometric view 
and drag to dimension the distance between two or 
more anchor points.
Vertical Axonometric Datum Dimension - Click a 
point of origin, then click multiple vertical points in 
axonometric view and drag to dimension the distanc-
es from the origin.
Axonometric Diameter Dimension - Click and drag 
a point on an axonometric circle to dimension its 
diameter.
Axonometric Radius Dimension - Click and drag 
a point on an axonometric circle to dimension its 
radius.
Axonometric Center line - Shift-click and drag to 
create the line in axonometric view.
Axonometric Object center - Click on an object 
line to mark the center of its bounding box 
in axonometric view.

click once on 
a line segment
and drag

click on multiple
points and drag

Axonometric dimensioning: Tools (cont.)

Horizontal Axonometric Dimension (by Line)
The Horizontal Axonometric Dimension (by Line) tool 
will dimension horizontal line segments in axonometric 
view. 

Select the Horizontal Axonometric Dimension (by Line) 
tool and position the cursor over the line to dimension. 
When the (      ) cursor appears, click the horizontal 
line and drag to position the dimension line. Hold 
down the shift key while dragging to offset the dimen-
sion line in increments. The offset increment value is 
set in the Snap distance field in the Dimension lines 
section of the CADdimensions panel. 

Horizontal Axonometric Dimension (by Points)
The Horizontal Axonometric Dimension (by Points) tool 
will dimension the horizontal distance between mul-
tiple points in axonometric view. Define the location of 
these points anywhere on the document.

Select the Horizontal Axonometric Dimension (by 
Points) tool and position the cursor at one end of the 
horizontal distance to dimension. If this is an anchor 
point, the cursor will change to (      ). Then click 
the mouse button once and release the mouse but-
ton. Position the cursor at the next point along the 
horizontal distance to dimension. Continue clicking 
on points along the horizontal distance until the last 
point is clicked, then drag to position the dimension 
line. Use the shift key while dragging to place the 
dimension line at a set distance from the object. The 
offset increment value is set in the Snap distance field 
in the Dimension lines section of the CADdimensions 
panel. Hold down the control key to create dimensions 
perpendicular to the axonometric object.

Note: For accurate measurements, make sure the 
artwork is arranged properly on one plane - to check 
this, flatten the artwork, adjust as needed and group 
before reprojecting it. If the artwork is properly 
constructed, axonometric dimension values should not 
change when the artwork and dimensions are flattened.
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Axonometric dimensioning: Tools (cont.)

Horizontal Axonometric Datum Dimension
The Horizontal Axonometric Datum Dimension tool 
will dimension the horizontal distances between 
a point of origin and other points in axonometric 
view in stacked style. Select the Horizontal 
Axonometric Datum Dimension tool and position 
the cursor at the origin on one end of the horizontal 
distance to dimension. If this is an anchor point, the 
cursor will change to (      ) . Then click the mouse 
button once and release the mouse button. Position 
the cursor at the next point along the horizontal dis-
tance to dimension. Continue clicking on points along 
the horizontal distance until the last point is clicked, 
then drag to position the dimension line. Use the shift 
key while dragging to place the dimension line at a set 
distance from the object. The offset increment value is 
set in the Snap distance field in the Dimension lines 
section of the CADdimensions panel. 

Horizontal Axonometric Chain Datum Dimension
The Horizontal Axonometric Chain Datum Dimension 
tool will dimension the horizontal distances between 
a point of origin and other points in axonometric view 
in chain style. Select the Horizontal Axonometric Chain 
Datum Dimension tool and position the cursor at the 
origin on one end of the horizontal distance to 
dimension. If this is an anchor point, the cursor will 
change to (      ) . Then click the mouse button once 
and release the mouse button. Position the cursor at 
the next point along the horizontal distance to 
dimension. Continue clicking on points along the 
horizontal distance until the last point is clicked, 
then drag to position the dimension line. The offset 
increment value is set in the Snap distance field in the 
Dimension lines section of the CADdimensions 
panel. 

To change the datum dimension terminator to a JIS 
terminator, check JIS terminator in the CADdimensions 
panel. 

click on multiple
points and drag

drag with 
the control key 
to create 
perpendicular 
dimensions

click once
on a line 
segment
and drag

click on 
multiple
points and 
drag

Axonometric dimensioning: Tools (cont.)

Vertical Axonometric Dimension (by Line)
The Vertical Axonometric Dimension (by Line) tool 
will dimension vertical line segments in axonometric 
view. A line segment is a path between two anchor 
points in Illustrator. 

Select the Vertical Axonometric Dimension (by Line) 
tool and position the cursor over the line to dimen-
sion. When the (      ) cursor appears, click the 
vertical line and drag to position the dimension line. 
Hold down the shift key while dragging to offset the 
dimension line in increments. The offset increment 
value is set in the Snap distance field in the Dimen-
sion lines section of the CADdimensions panel. 

Vertical Axonometric Dimension (by Points)
The Vertical Axonometric Dimension (by Points) tool 
will dimension the vertical distance between multiple 
points in axonometric view. Define the location of 
these points anywhere on the document.

Select the Vertical Axonometric Dimension (by Points) 
tool and position the cursor at one end of the vertical 
distance to dimension. If this is an anchor point, the 
cursor will change to (      ) . Then click the mouse 
button once and release the mouse button. Position 
the cursor at the next point along the vertical dis-
tance to dimension. Continue clicking on points along 
the vertical distance until the last point is clicked, 
and then drag to position the dimension line. Use the 
shift key while dragging to place the dimension line 
at a set distance from the object. The offset increment 
value is set in the Snap distance field in the Dimen-
sion lines section of the CADdimensions panel. 

click on multiple
points and drag

drag with 
the control key 
to create 
perpendicular 
dimensions
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Axonometric dimensioning: Tools (cont.)

Vertical Axonometric Datum Dimension
The Vertical Axonometric Datum Dimension tool 
will dimension the vertical distances between 
a point of origin and other points in axonometric 
view. 

Select the Vertical Axonometric Datum Dimension 
tool and position the cursor at the origin on one end 
of the vertical distance to dimension. If this is an 
anchor point, the cursor will change to (      ) . Then 
click the mouse button once and release the mouse 
button. Position the cursor at the next point along 
the vertical distance to dimension. Continue clicking 
on points along the vertical distance until the last 
point is clicked and then drag to position the dimen-
sion line. Use the shift key while dragging to place 
the dimension line at a set distance from the object. 
The offset increment value is set in the Snap distance 
field in the Dimension lines section of the CADdimen-
sions panel. 

Vertical Axonometric Chain Datum Dimension
The Horizontal Axonometric Chain Datum Dimension 
tool will dimension the horizontal distances between 
a point of origin and other points in axonometric 
view in chain style. Select the Vertical Axonometric 
Chain Datum Dimension tool and position the cursor 
at the origin on one end of the horizontal distance to 
dimension. If this is an anchor point, the cursor will 
change to (      ) . Then click the mouse button once 
and release the mouse button. Position the cursor 
at the next point along the vertical distance to 
dimension. Continue clicking on points along the 
vertical distance until the last point is clicked, then 
drag to position the dimension line. The offset incre-
ment value is set in the Snap distance field in the 
Dimension lines section of the CADdimensions panel. 

To change the datum dimension terminator to a JIS 
terminator, check JIS terminator in the CADdimen-
sions panel. 

click on multiple
points and drag

click on the 
circle path
and drag

click on the 
circle path
and drag

Axonometric dimensioning: Tools (cont.)

Axonometric Diameter Dimension
Select the Axonometric Diameter Dimension tool and 
position the cursor over the path of an axonometric 
circle. When the (      )  cursor appears, click and 
drag to position the diameter dimension. Hold down 
the shift key while dragging to constrain the tool to 
axonometric multiples of 45°. Hold down the control 
key while dragging to toggle the placement of the 
diameter dimension text.

Axonometric Radius Dimension
Select the Axonometric Radius Dimension tool and 
position the cursor over the path of an axonometric 
circle. When the (      )  cursor appears, click and 
drag to position the radius dimension. Hold down 
the shift key while dragging to constrain the tool to 
axonometric multiples of 45°. Hold down the control 
key while dragging to toggle the placement of the 
radius dimension text.

Note: To quickly toggle between radius dimension and 
diameter dimension, use the alt/option key.
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Axonometric dimensioning: Tools (cont.)

Axonometric Center Line
The Axonometric Center Line tool creates a center 
line that constrains to the current axonometric 
angles. Select the Axonometric Center Line tool and 
position the cursor at the beginning of the desired 
line. Click and drag to position the line, then release 
the mouse button to create the line. Hold down the 
shift key while dragging to constrain the tool to the 
current axonometric view angles (set in the CADax-
onometric panel).

Axonometric Object Center
Select the Axonometric Object Center tool and posi-
tion the cursor over the path of a circle or object. 
When the (     ) cursor appears, click once and 
release the mouse button to create the object center 
in axonometric view.

click and
drag

click on an 
object path

Using numeric input
Create artwork to scale by numerically specifying dimensions 
for CADtools drawing tools. Select the tool and click once to 
begin creating the shape. While using a centered tool, the 
click location will define the center of the object; otherwise, 
the click location will define a corner of the object. A numeric 
input dialog box will appear, displaying the dimensions last 
specified for that tool. 

Setting units throughout CADtools
Use the CADunits panel to set up units and precision for all 
dimension values and interface settings like numeric input, 
CADrulers and CADpanel options.

Use the following unit abbreviations:
1) Points: pt
2)  Pixels: px
3) Picas: p
4) Millimeters: mm
5) Centimeters: cm
6) Meters: m
7) Kilometers: km
8) Mils: mil
9) Decimal inches with symbol: X.X“
10) Fractional inches with symbol: X X/X“
11) Decimal inches with units: X.X in
12) Fractional inches with units: X X/X in
13) Decimal feet and inches with symbol: X' X.X“
14) Fractional feet and inches with symbol: X' X/X“
15) Decimal feet and inches with units: X ft X.X in
16) Fractional feet and inches with units: X ft X/X in
17) Decimal feet with symbol: X.X'
18) Decimal feet with units: X.X ft
19) Miles: mi

Note: If a unit is not specified in numeric input, the artwork will 
be drawn in the units specified in the CADunits panel.

Quick Reference: Numeric input and units
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angle dimensioning 
without the control key

45°

Quick Reference: Keyboard shortcuts

angle dimensioning 
with the control key

Keyboarding for precision and shortcuts
CADtools utilizes the shift, alt/option, and control keys to provide 
more control and flexibility while drawing and dimensioning. Note: 
these keys only function by holding them down after selecting and 
beginning drafting or dimensioning with one of the tools. 

Use the shift key to constrain most CADtools 2D drafting and 
dimensioning tools to multiples of 45°.

To quickly switch between certain tools in CADtools, use the alt/
option key (alt for Windows and option on Mac) while dragging 
to toggle between the following 2D and axonometric tools: 
1) Rectangle and Centered Rectangle
2) Ellipse and Centered Ellipse
3) Arc (by radius) and Arc (by endpoints)
4) Horizontal Dimension by Point and Vertical Dimension by Point
5) Horizontal Dimension by Line and Vertical 	
 Dimension by Line
6) Horizontal and Vertical Datum Dimension
7) Radius and Diameter Dimension
8) Tangent Dimension: Shows normal/perpendicular line 

Use the control key for variations in dimensioning artwork. 
The control key provides the following tool variations:
1) Arc: complementary arc
2) Section Line: adjacent placement of label
3) Angle Dimension: complementary angle
4) Arc Length Dimension: complementary arc length
5) Diameter Dimension: adjacent placement of label
6) Radius Dimension: adjacent placement of label
7) Bézier Curvature Dimension: arc visibility
8) Tangent Dimension: placement of normal line
9) All label tools: adjacent placement of label

To remove witness lines while drawing angle 
dimensions, use the alt/option key while dragging 
with the angle dimension tool.

Hold the alt/option key down when projecting 
artwork with the cube icon to automatically expand it.

Use the control key to constrain the CAD Line tool 
to the angle started while dragging.

315°

Cursor feedback
While drawing and dimensioning with CADtools, receive additional 
precision cursor feedback to help select lines and anchor points in 
the correct order. 

Precision cursor 

Precision cursor 
over path

Precision cursor 
over anchor point

Precision cursor 
waiting for second click

Cursor dragging 
to create artwork

Cursor over 
dimension line

CADtools drawing, editing, dimensioning 
or labeling tool is selected

Tool is selected and cursor is directly over a path

Tool is selected and cursor is directly over an 
anchor point

Tool is selected, first click has been made, waiting 
for click or click-drag to create artwork

Tool is selected,  first or second click has been made, 
and cursor is dragging

Cursor is directly over a dimension line and a 
dimension cannot be created

Activity statusCursor description

Quick Reference: Cursor feedback

Dimensioning objects
When dimensioning by points, be sure to use the precision 
cursor over the anchor points to properly dimension the object. 
Inaccurate measurements will result if the dimensions are pulled 
from the lines rather than the anchor points.

When Free sliding text is checked in the CADdimensions panel, 
dimension text can slide while dragging. To lock it into center 
position, use the control key while dragging.

3.53 cm

with Free sliding text checked

3.53 cm

with Free sliding text checked
holding the option key
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Advanced topics

Saving artwork
Save artwork in Illustrator CS or higher format or the 
dimension information may not display properly.

Importing or exporting artwork
Adobe Illustrator CS3, CS4, CS5, CS6 and CC include DXF and 
DWG import and export in R13, R14, 2000, and 2004/2005/2006 
formats. Once a file is imported as vector artwork inside Adobe 
Illustrator, CADtools can be used to dimension or edit the 
artwork. In some cases, an imported file may contain artwork 
comprised of small line segments. Dimensioning tools by line, 
as well as radius, diameter, arc length, and Bézier curvature 
dimensioning tools will not work for such segmented artwork. 
To connect these DXF line segments, use the Concatenate filter 
available at (http://rj-graffix.com/) For more information 
on opening or placing files within Illustrator, please refer to the 
Adobe community forums and the Adobe web site at 
www.adobe.com.

Symbol, patterns, and additional tools
• Hot Door CADpatterns: 134 patterns for technical drawing
• Hot Door Dwell Symbols: Samples of architecture
• Code Zebra TechSymbols in seven libraries: Architecture, Build-
ing Services, Landscaping, Electrical, Mechanical, Fasteners and 
General
• DGI SignSymbols: Road sign graphics
• GDS Drop3D: 3D model manipulation and import tool

Check the Hot Door Web site for updates on these and other 
design resources as they become available.

Keyboard shortcuts
Adobe Illustrator includes Keyboard Shortcuts for making cus-
tom shortcuts. The tools in CADtools can be accessed with key-
board shortcuts that can be defined by choosing Edit > Keyboard 
Shortcuts. Create separate sets for different workspaces chosen 
from the Window > Workspace menu. 

Using pressure-sensitive input devices 
When using tablets or other pen-based devices, CADtools may 
require additional pressure for clicking and dragging. To set this 
pressure sensitivity, choose Window > CADtools > Preferences... 

Advanced topics (cont.)

Using CADtools full screen cursors and Smart Guides
Adobe Illustrator includes Smart Guides that help create, align, 
edit and transform objects. Smart Guides works 
with CADtools for optimal precision and 
control when manipulating artwork. The 
CADguides panel offers Full screen cursors for 
precision when creating lines or objects with 
CADtools.

Duplicating objects with dimensions
Any dimensions linked to objects that have been duplicated with 
the alt/option-drag keys may not update correctly in CS3, CS4 
and CS5. To duplicate objects with dimensions, copy and paste 
the objects with their dimensions using menu or command 
keys. To avoid unpredictable results, detach dimensions prior to 
copying and pasting them into new documents.

Drawing in the dimension layer
Dimensions will automatically draw into a separate layer named 
“Dimension Layer” if 'Create and use dimension layer' is checked 
in the CADtools Preferences under Window > CADtools > Prefer-
ences... This Dimension layer can be hidden, locked, displayed, 
and printed like other layers created within Illustrator. All 
objects drawn in the dimension layer will be 1:1 scale. Avoid 
using the Dimension Layer for creating other artwork and make 
sure the appropriate layer is selected while drawing.

Bézier curvature dimensioning for circles and arcs
Circles and circular arcs created within Illustrator are 
constructed with Bézier curves. Therefore, the radius at any 
point of a circle or circular arc may reveal a variance of up 
to 5% of the original specified radius.

Deleting Adobe Illustrator CS6 or CC Preferences
If Illustrator is not performing as expected, it may help to delete 
the Adobe Illustrator CS6 or CC Preferences files. 
On Mac OS X platforms, the Preferences file is found by using 
the Finder's Window > Go > Go to Folder... menu and typing: ~/
Library/Preferences/Adobe Illustrator CS6 Settings (or Adobe 
Illustrator 17 Settings)/. 
On Windows, use this path: 
C:\users\yourname\AppData\Roaming\Adobe\Adobe Illustrator 
CS6 Settings (or Adobe Illustrator 17 Settings)\en_US\Adobe 
Illustrator Prefs. 

center

x



9998

Advanced topics (cont.)

Using CADgrids
CADgrids increments are logical divisions of the units defined 
in the CADunits panel.

Drawing axonometric/isometric objects
For best results, create a simple axonometric cube before 
creating artwork and adjust the view angles. For separate 
axonometric shapes that share the same plane, first create 
them as flat artwork. Then project them to the front, side, 
or top plane with the cube in the CADaxonometric panel.

Area values for intersecting or compound paths
The area of a path that intersects itself cannot be calculated 
correctly by the CADtracker panel. Area can be calculated for 
single or multiple shapes as long as they are closed and do not 
include overlapping compound paths.

Using patterns in axonometric view
Patterns are not automatically transformed with CADtools 
objects, but a transformation of pattern artwork can be forced 
by expanding and projecting it with flat artwork using the 
CADaxonometric panel.

Smoothing sharp axonometric artwork
The geometry of axonometric objects may naturally show many 
sharp angles in the artwork. If artwork is stroked, select it and 
choose Round Join in the Illustrator Stroke panel for a cleaner 
appearance.

Scroll bar display in CADtools panels
On Mac systems, scroll bars will not appear inside CADtools 
panels – CADaxonometric, CADscale, and CADshortcuts – 
unless scroll bars are set to Always show under the 
Apple menu > System Preferences > General panel. 

Index

Chain datum dimension  
44, 46, 48
Chamfer  73
Circle  23
Constrained Line  26
Control Bar  21
Corner Profile  74
Converting older files  10
Creative Cloud  7
Cursor feedback  95
Custom label  59
Custom scale  15

D

Datum feature  61
Datum flag  62	
Datum target  61
Demo Version  9			 
Diameter dimension  50
Dimensioning tool group  42
Dimension Redo  50
Door insertion  33
DXF/DWG  96

E

Ellipse  23
Expand  79, 81
Extend  76

F

Fillet  72
Fillet radius dimension  50
Flatten  79, 81
Full screen cursor  97

G

Geometry in CADtracker  66
Geometry label  60

3-point circle  24

A

Activation  9
Add Wall  29-31
Advanced Topics  96-98
Alt/option key  94
Angle dimension  42, 49
Arc (by points)  24
Arc (by radius)  24
Arc length dimension  42, 49
Area  60, 66, 68
Area Transform  68
Attach dimensions/label  56
Auto-expand  79, 81
Automatic dimensioning  40
Axonometric center line  92
Axonometric cube  85
Axonometric cylinder  85
Axonometric diameter dimension	 91
Axonometric ellipse  84
Axonometric grid  85
Axonometric object center  92
Axonometric radius dimension  91
Axonometric rectangle  83

B

Bezier curvature dimension  51

C

CADguides panel 18
CADaxonometric panel  12, 79-81
CADlabels panel  53-55
CADpresets file  40-41
CADdimensions panel  35-39
CADscale  14
CADtracker panel	  66-70
CADunits panel  19-20
CADwalls panel  29-30
Centered ellipse  24
Centered rectangle  23
Center Line  52
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H

Horizontal datum dimension
44
Horizontal dimension 
(by line)  43
Horizontal dimension 
(by points)  43
Horizontal axonometric datum 
dimension  87-88 

I

Icons  11
Importing older files  10, 96
Inclined dimensioning  47-48
Incremental labeling  57-58
Installation  8-9

K

Keyboard shortcuts  94
Key object (proportion)  78

L

Labeling tools  57-62
Layer scales  14
Legacy text  10
License agreement  4
Line  25-26

M

Measure distance  77
Measure scale  76
Move  69
Move wall  32

O

Object Center  52	
Offset  27

P

Path Divider  76
Patterns  96
Perpendicular  27
Personalization  9

Preferences  13
Presets  40-41
Projection  79-80
Proportion  77-78

R

Radius dimension  50
Rectangle  23
Repeat  70
Revision bubble  62
Rounded rectangle tool  23
Rise, run  26
Rulers  18

S

Scale  14-17
Section line  62
Serial number  9
Shortcut keys  94
Sliding text  37, 95
Span circle  39

T

Table tool  65
Table of contents  3
Tangent  27
Title block  63-64
Transform  67
Trim  75

U

Unit abbreviation  20, 93

V

Vertical datum 
dimension  46
Vertical dimension 
(by line)  45
Vertical dimension 
(by points)  46

W

Wall  28-32
Window insertion  34


