DreamWeaver,经典50问(目录)
作者：TNT / 太平洋网络学院
［责编:爆破手］

    说明：本文原件来自 [太平洋电脑站] 由 [中华电脑书库] 整理编译；仅供个人学习交流研究之用，版权归原作者所有；欢迎访问 [中华电脑书库] 获取更多电脑书籍！

特别推荐：透明网络--国际域名一级注册商，美国NAC、HE合作伙伴！
国际域名75元/年 送域名证书和自主管理系统，100%自己管理！
特别提供美国空间、美国服务器，把网站建在美国，好处多多！！

大家在使用 Dreamweaver 过程中，可能会遇到这样或那样的问题，你可能迎刃而解，也可能束手无策。为此，“笨笨熊”总结了以下五十道在设计过程中经常遇到的或者技巧性的问题，希望可以帮助到您！

DreamWeaver,经典50问(一)

1> 在DW中，如何输入一个空格呢？

2> 如何在浏览器地址栏前添加自定义的小图标？

3> 为什么，我本来设计很好的网页，在浏览器窗口最小化时会变的丑陋难堪？

4> 如何改变网页显示时，最顶部的提示信息？

5> 怎么样，才能为图片添加指定颜色的边框？

DreamWeaver,经典50问(二)

6> 如何添加图片及链接文字的提示信息？

7> 如何把自己的ZIP或其他类型的文件供别人下载?

8> 怎样才能够保证网页中文字不跟随浏览器字体大小设置而变动?

9> 以新窗口的形式打开目标链接？

10> 如何让网页载入时，象许多商业网站那样，弹出一个广告窗口

DreamWeaver,经典50问(三)

11> 我的快速启动板中没有"Timelines"，怎么办？

12> 作一个网页让它可以每隔5分钟自动刷新一次，如何实现？

13> 如何定义网页的关键字（Keyname）？

14> 如何在编辑窗口中，隐藏一些不必要的标签？

15> 安排不支持“框架”的浏览器的显示内容？

DreamWeaver,经典50问(四)

16> 如何避免别人把你的网页放在框架中？

17> 怎样加入注释内容？

18> 水平线，为什么不能设置颜色？

19> 如何设置可以关闭当前窗口的功能？

20> 定时自动关闭的窗口又是怎样的呢？

DreamWeaver,经典50问(五)

21> 如何更改浏览器中鼠标的"形状"?

22> 如何去除掉链接文字下面的下划线？

23> 怎样让鼠标在链接文字上方“悬停”时，产生变色，变形等效果？

24> 如何让网页的背景图片不跟随内容滚动？

25> 背景音乐你一定知道吧，怎么添加呢？

DreamWeaver,经典50问(六)

26> 如何利用水平线制作一条宽度为1的细线？ （编者增加）

27> 如何自动加入网页更改后的日期？

28> 怎样控制弹出POPUP信息？

29> 隐藏浏览器中状态栏的URL地址信息的方法？

30> 如何改变状态栏里的提示文字？

DreamWeaver,经典50问(七)

31> 如何建立电子邮件的表单处理方式?

32> 怎样制作规范的电子邮件链接？

33> 如何制作“空链接”？

34> 点击空链接时，页面往往重置到页首端，如何处理？

35> 如何定制可自由在页面内跳转的链接？

DreamWeaver,经典50问(八)

36> 同时在一个图片上，作很多个链接，怎么办？

37> 怎样制作可以响应鼠标事件的翻转图片？

38> 如何制作“漫天飞舞”的图片？

39> 怎样制作在页面中“静态悬浮”的图片？

40> 如何使文字和图片内容共处？

DreamWeaver,经典50问(九)

41> 实现多个窗口的连接?

42> 如何在网页中隐藏一些内容？

43> 怎样创建一个简单下拉菜单？

44> 如何制作一条宽度为1的细线？

45> 如何制作一个边框为1的方格？

DreamWeaver,经典50问(十)

46> 怎样设置根据不同的浏览器，返回不同的页面？

47> 网页中可以随便拖动的对象是怎么建立的？

48> 如何为网页添加一个外部的风格样式表（CSS）

49> 设定网页的Base（基地址）有什么用途？

50> 如何精确的定位网页中的内容？

[下一页]

透明网络--国际域名一级注册商，美国NAC、HE合作伙伴！


DreamWeaver,经典50问(一)
作者：笨笨熊 / 太平洋网络学院

[导读] 作者:笨笨熊

    Dreamweaver一直是不少网友钟情的网页设计工具，除了它强大的动态效果制作能力外，方便简洁的操作界面更是独具特色，下面我们将以最新版本Dreamweaver4为例，并以提问的方式系统的介绍下，在设计过程中经常遇到的一些问题和技巧性的东西。

注意：为了方便，以下我们将Dreamweaver全部减缩为DW表示。

1> 在DW中，如何输入一个空格呢？

    输入空格的问题，在DW似乎已成了一个老生常谈的问题，我们可能在许多介绍DW使用方面的书籍或文章中看到过N次。

    DW中对空格输入的限制是针对“半角”文字状态而言的，因此通过将输入法调整到全角模式就可以避免了，方法是：打开中文输入法（以人工智能ABC为例），按Shift+Space切换到全角状态，现在应该没问题了。

    此外，你还可以通过许多“变通”的方法达到录入空格的目的，比如常用的是：

    直接在源代码中加入代表空格的HTML代码“&nbsp”；输入一定长度的文字对象后，然后调整文字的颜色与当前的背景颜色相同等等，不过注意的是后者在一些浏览器中可能显示上有点问题。（呵呵，当时俺用的那个就是让王晨昀给看出来的！）

2> 如何在浏览器地址栏前添加自定义的小图标？

    你是不是记得有时在浏览网易网站的首页时，在地址WWW。163。COM前会显示一个“易”字样的小图标。而默认情况下，这个图标是一个IE浏览器的指定图片。如图：

dwquestion1.gif (7632 bytes)

    其实这也不是什么高深技术，只不过在网站目录下添加了一个特定文件而已。

    这时，我们需要预先制作一个图标文件，大小为16*16像素。文件扩展名为ico，然后上传到相应目录中。在HTML源文件“<head></head>”之间添加如下代码：

<Link Rel="SHORTCUT ICON" href="http://图片的地址（注意与刚才的目录对应）">

    其中的“SHORTCUT ICON”即为该图标的名称。当然如果用户使用IE5或以上版本浏览时，就更简单了，只需将图片上传到网站根目录下，即可自动识别！

3> 为什么，我本来设计很好的网页，在浏览器窗口最小化时会变的丑陋难堪？

    这应该是个很值得大家注意的问题，也就是说，在全屏状态下浏览网页内容时，一点问题也没有。当我们使用窗口的最小化命令或手动的调整窗口的大小时，问题就慢慢出现了。网页内容会把当前窗口作为显示范围，依次下挫。举个例子，和在记事本中有“自动换行”和“没换行”的差别是完全一样的。

    解决这个问题，我们必须从网页的布局说起，一般情况下，网页内容的定位大多是通过表格来实现的。因此问题的“毛病”也就出在表格上。

请看下面一个表格的属性面板显示：

dwquestion2.gif (2539 bytes)

    你可能已经注意到了，在表格的高宽设定选择上提供了两种不同的类型，百分比和像素。其中百分比的使用将会产生前面说到的那个毛病，将其全部更正为Pixels单位的实际大小就可以了。

4> 如何改变网页显示时，最顶部的提示信息？

    浏览网页时，顶部的提示信息往往代表了网页内容的关键所在，有助于访问者提前了解网页内容。在DW4前，没有在功能上直接提供该操作，我们往往通过在源代码中应用“Title”属性来完成。进入DW4就简单多了。

dwquestion3.gif (478 bytes)

    直接在编辑窗口最上方的“Title”输入框内键入所需要的文字信息即可。

5> 怎么样，才能为图片添加指定颜色的边框？

    对于没有边框的图片而言，直接插入到网页中，在显示效果上是相当差的。记得在微软的FP中要给图片添加满意的边框还是相当麻烦的。

    不过在DW中就显得容易多了，因为这里有一个“Border”属性，可以让你直接设置边框的宽度。如图：

dwquestion4.gif (2220 bytes)

    宽度设好了，你一定会问，颜色呢？面板上并没有提供颜色的选择呀！呵呵，其实这里有一个技巧问题，用鼠标选择图片对象，注意不是点击选中，而是拖动选择。象设定文字颜色一样进行就可以了。

[下一页] [目录]

透明网络--国际域名一级注册商，美国NAC、HE合作伙伴！

版权所有©2000 太平洋电脑网


DreamWeaver,经典50问(二)

6> 如何添加图片及链接文字的提示信息？

    在我们浏览网页时，当鼠标停留在图片对象或链接上时，在鼠标的右下有时会出现一个提示信息框。对目标进行一定的注释说明。在一些场合，它的作用是很重要的。

    下面先看看图片提示信息的添加，选中图片对象，在属性面板里你会发现有个“Alt”输入框。默认情况下，该输入框是空白的。在这里录入需要的提示内容就可以了。

    那么链接提示的制作就没这么简单了。因为DW中没有直接提供该功能，因此我们需要通过添加HTML代码来实现。

    在<a href=“” >中添加“Title”属性。Title=提示内容即可。

7> 如何把自己的ZIP或其他类型的文件供别人下载?

    在不少初级网页制作者看来,好象通过鼠标单击完成下载是件很"神秘"的事,实际上远非如此.在DW中凡是不被浏览器识别的格式文件(HTM,HTML,ASP,PHP.PERL,SHTML等以外的)作为链接目标时,默认的操作都是下载.

    这时你只需要,把要浏览者下载的文件名写好,然后制作一个到目标文件的链接.注意目录一定不要搞错.

8> 怎样才能够保证网页中文字不跟随浏览器字体大小设置而变动?

    大家都知道,在IE浏览器的功能设置中，有一个可以自由设置窗口内容字体大小的功能，这样由于不同访问者的习惯问题，呈现在他们面前的网页有时也会不同。

    比如你可能本来设计时用的是2号字体，结果由于用户对浏览器的额外设定，变的更大了，这时显示效果上就出问题了。

    那么解决的办法就是将网页内容定性的强制在某个合适的大小上。即不容许他变化。通过CSS样式表对字体进行强制性控制就可以实现这个要求了。

9> 以新窗口的形式打开目标链接？

    以新窗口打开，顾名思义，也就是在不覆盖当前窗口的前提下，另外打开一个浏览器窗口。你可以直接在连接代码中<a href="" >加入“Target=_blank”。

    如果你的HTML比较差的话，在DW属性面板上同样提供了这个设置，当你在Link输入框中键入WWW网址时，后面的Target下拉框同时也被激活了。如图

dwquestion5.gif (3294 bytes)

    选择最上的“blank”就可以了。

10> 如何让网页载入时，象许多商业网站那样，弹出一个广告窗口

    这在不少大型商业网站中，是时常见到的。在DW中可以轻松通过Behavior行为实现。

    既然是载入时，我们可以把整个网页内容视为事件对象。在DW编辑窗口中鼠标点击左下角的“<body>”标签，这时你能注意到全部网页内容已经选中了。

    单击“快速启动板”中的“Behavior”按钮，进入行为面板，如图：

dwquestion6.gif (7742 bytes)

    选择“Open Browse Window”项，这时你还可以对窗口样式进行自定义，比如大小，工具按钮的保留等等。另外还有一点就是别忘了对应的事件是“Onload”.

[上一页] [下一页]


DreamWeaver,经典50问(三)

11> 我的快速启动板中没有"Timelines"，怎么办？

    DW从升级到4版本后，在快速启动板中增添了几个新的项目，比如Assets等等。这时原来在上面的Timelins（时间线）按钮被挤了下去。

    当然如果你急于现在就使用它的话，仍然可以通过菜单“Windows”-“Timelines”找到。不过毕竟不如放在启动板中方便，这时我们能通过设置把它添加进来！

    “Edit”-“Preference”进入窗口，在左边的项目列表中选择“panels”（面板），如图

dwquestion7.gif (2113 bytes)

    单击上面的“+”号按钮，从下拉列表中选择“Timelines”。这时时间线已经自动添加到当前的“Show in Launcher”列表内容里，OK。更改后的“Launcher”面板如图。

dwquestion8.gif (1808 bytes)

    同时你还可以根据自己的需要自由的选择面板中出现的按钮选项，以提高工作效率。

12> 作一个网页让它可以每隔5分钟自动刷新一次，如何实现？

    上网浏览时，我们经常会遇到一些网页。在隔一段时间没有响应时，它会自动刷新一次。除了可以起到提醒访问者的目的外，当新的刷新地址不是当前URL时，实现的就是自动跳转的功能。

    无论是重复刷新，还是自动跳转。在网页设计中，都是相当实用的操作。下面我们来介绍下它们的制作方法。

    选择DW“Object”面板的“Head”部分，注意默认情况下，显示的是Common的“内容”。如图

dwquestion9.gif (4730 bytes)

    单击上面的“Refresh”按钮，弹出窗口如下：

dwquestion10.gif (4783 bytes)

    其中“Delay”输入框中键入刷新延迟的时间（单位：秒），“Action”为刷新指定的目标URL。因为现在是刷新当前页面，直接选单选项“Refresh This Document”即可。

13> 如何定义网页的关键字（Keyname）？

    当用户使用搜索引擎search合适内容的网页时，关键字起着一个不容忽视的作用。大多的搜索服务器会每隔一段时间自动探测网络中是否有新网页产生，并把他们按关键字进行记录，以方便用户查询。

    你当然想让你的网页出现在搜索引擎的查询返回列表中了，这时关键字的定义就尤为重要了。

    同样在“Head”面板部分，如图

dwquestion11.gif (4708 bytes)

    单击“Keywords”按钮，弹出定义窗口如下：

dwquestion12.gif (5344 bytes)

    录入需要逐个定义的关键字即可，注意每个关键字以“；”号隔开，数目没有限制。

14> 如何在编辑窗口中，隐藏一些不必要的标签？

    当用户在网页中插入了太多的不可见元素时，在编辑窗口的最上面就会显示一排相应的标示标签，用来方便用户随时能找到它们。虽然这些标签本身并不影响浏览器里的显示效果，但多了以后，往往使网页内容不得不错位，从而一定程度上妨碍网页视觉上的调整，那么怎么样才能把这些东东去掉呢？

    进入“Preperence”面板，列表中选择“Invisibel Elements”，如图：

dwquestion13.gif (3474 bytes)

    勾掉你不想显示的项目前的“对号”即可，比如Scripts等

15>安排不支持“框架”的浏览器的显示内容？

    我们知道，目前的浏览器类型很多，因此我们设计网页时最先考虑到的往往是“这个东西是不是在不同的浏览器中都能显示好呢？”。框架就是一个例子！

    不过避免开这点，很简单，你只需要在源代码中加入下面的内容就可以了。

    < BODY><noframes> ---本网页中包含有框架结构，如果您不能正常显示的话，请下载新的浏览器版本或更换主流浏览器--- < /noframes></ BODY>


DreamWeaver,经典50问(四)

16> 如何避免别人把你的网页放在框架中？

    一些居心不良的人，经常偷着窃取别人的劳动成果，比如把别人精心制作的网页以子页的形式放到自己的框架中。

    那么怎样避免自己的网页内容被“盗用”呢？

    你只需要在网页源代码的<head></head>之间加入以下代码内容：

<script language=“javascript”><!--
if (self!=top){top.location=self.location;}
-->< /script>

17> 怎样加入注释内容？

    注释内容，顾名思义只是作为说明内容出现的，因此在浏览时不会出现在网页中。它的作用是对某些重要或复杂代码进行必要的标示，以更方便快捷的找到。

    进入“Object”面板的“Invisibel”部分（即不可见元素），选择插入“Comment”按钮，窗口如下：

   dwquestion14.gif (5805 bytes)

    在“Comment”中键入必要的信息。这时如果你返回到源代码中，会看到这些操作添加的不过是下面格式的一段代码：

<！--这是需要填写的注释内容-->

18> 水平线，为什么不能设置颜色？

    在DW中，当通过菜单“Insert”-“Horizonal Rule”插入水平线时，在属性面板中你会发现并没有提供关于水平线颜色的设置，因为最早NC中不支持标签<hr>（水平线的HTML代码）的COLOR属性，所以DW也没有关于它的设置。如图

dwquestion15.gif (2334 bytes)

    看来需要的话，我们只能直接进入源文件更改了。

<hr color="对应颜色的代码">

19> 如何设置可以关闭当前窗口的功能？

    这里我们可以先输入用来标示的文字“关闭窗口”，用鼠标拖动选中它，在“Link”输入框中键入“/”，同时切入源代码窗口，在链接代码中键入该事件-onclick=“javascript:window.close(); return false;”。

    完整的代码为：< a href=“/”onclick=“javascript:window.close(); return false;”>关闭窗口< /a>

    当然你也可以将文字“关闭窗口”换成其他的对象，比如图片，按钮等等！

20> 定时自动关闭的窗口又是怎样的呢？

    上面提到了个关闭窗口的功能，那么现在的自动关闭又是怎么实现的呢？

    在源代码<body>后加入下面的代码：

< script LANGUAGE=“JavaScript”> <!--
setTimeout('window.close();', 10000);
--> < /script>

    其中的set Timeout是一个用来设定延迟时间的函数，这里10000表示10秒钟。


DreamWeaver,经典50问(五)

21> 如何更改浏览器中鼠标的"形状"?

    一般情况下，鼠标在浏览器中以“箭头”的样式出现，那么我们能不能把它更改为自己喜欢的其他样式类型呢？

    改变鼠标形状在DW中是通过“CSS样式表”来实现的。

    菜单“文字（Text）”-“CSS样式表（CSS Style）”-“Edit style sheet”，弹出样式表的编辑窗口，也可以单击快速启动板中的CSS Style按钮找到，如下

dwquestion16.gif (6354 bytes)

    单击“New”按钮，选择默认的“Make custom style”，同时在下面的Define中使该样式只应用到当前网页文档，“This document only”。

    在“样式定义”窗口的左边列表项中选择“Extensing”（扩展项），相应右边设置如图

dwquestion17.gif (1904 bytes)

    在“Cursor”（鼠标）中，下拉选择合适的形状即可，确定后返回，按F12在浏览器中观察效果，不满意的话，还可以对样式进行修改。

22>如何去除掉链接文字下面的下划线？

    在我们完成链接制作后，链接文字内容往往被自动在下面添加一条下划线，用来标示该内容包含超级链接。当一个网页中链接比较多时，就显得有些杂乱的感觉了，其实我们可以很方便的把它去掉。

    同样进入“Edit style sheet”窗口，单击“New”确立新样式，如下

dwquestion18.gif (6645 bytes)

    这里的Type（类型）中，需要选择的是“Redefine HTML Tag”，同时在具体的标记Tag中选中代表超级链接的“a”，单击OK。

    编辑该样式，左边列表中选“Type”，如下

dwquestion19.gif (3320 bytes)

    勾取“Decoration”（修饰）中的“None”复选框，这时所有网页中的链接文字下划线都被清除掉了。


DreamWeaver,经典50问(五)

23> 怎样让鼠标在链接文字上方“悬停”时，产生变色，变形等效果？

    访问网站时，我们遇到的最平常不过的一种效果就是“鼠标悬停响应”了，所谓的“鼠标悬停响应”表现在链接文字上，就包括改变颜色，修饰效果（下划线，中划线）等多种选择。

    由于这种效果很好的起到了对目标内容的强调作用，因此无论是个人网站还是一些大的商业网站（如新浪，搜狐，网易等）都有应用。

    在上个问题中，你已经知道了去除掉链接下划线的方法，这里不再赘述。下面的问题将是如何添加鼠标响应事件的过程。

    同样进入“Edit style sheet”窗口，单击“New”确立新样式，不同的是现在的Type类型中选择最后的一项-“Use CSS selector”，“Selector”选单中选择“a:hover”如下

dwquestion20.gif (6796 bytes)

    OK，进入编辑样式窗口，设定“Type”项中的文字颜色为“红色”，当然你还可以添加鼠标悬停时出现下划线的效果。

24>如何让网页的背景图片不跟随内容滚动？

    背景图片是很多网页设计者经常添加的东西，当网页内容超出一屏时，拉动滚动条背景图片会与内容相对静止的一起滚动，那么能否锁定背景不跟随滚动呢？当然可以进入“Edit style sheet”窗口，单击“New”确立新样式，在TYpe中选择“Redefine HTML Tag”，同时Tag选单选中“Body”，在左边列表中选择“Background”。如下

dwquestion21.gif (2843 bytes)

    设定“Attachment”（附件）为“fixed”。其中scroll代表默认使用的滚动显示。


DreamWeaver,经典50问(五)

25> 背景音乐你一定知道吧，怎么添加呢？

    在微软的网页工具-Frontpage中，有关于背景音乐的设置功能，那么DW显然没有作到这点，因此要使用的话，只能在源代码中手动添加了。

    在使用前，提醒大家一点，使用背景音乐一定要注意网页文件的大小，不能顾此失彼。

代码如下：

< EMBED src=“music.mid”autostart=“true”loop=“2”width=“80”height=“30”>

    其中src指定音乐文件的位置，autostart为音乐文件上传后的动作，true表示自动开始播放，false不播放（默认值）。


DreamWeaver,经典50问(六)

26> 如何利用水平线制作一条宽度为1的细线？
1.在 Dreamweaver 中新建一个文档，插入一条水平线，双击水平线，调出属性面板。

    2.在水平线的属性面板上设置高度 H = 0 pixel。

    3.Copy 此条水平线，在属性面板中把 Shade 的勾点掉。

    4.按 F12 进行预览，请对比下面的（1）（2）源代码及效果。

(1)

源代码：<hr size="0" color="#3366FF" noshade>

(2)

源代码： <hr size="0" color="#3366FF">

    5.另外制作两条 H = 1 pixels 的水平线，分别有 Shade 和 没 Shade。

(1)

源代码：<hr size="1" color="#3366FF" noshade>

(2)

源代码： <hr size="1" color="#3366FF">

    6.制作两条 H = 2 pixels 的水平线，并定义颜色，分别有 Shade 和 没 Shade。

(1)

源代码：<hr size="2" color="#3366FF" noshade>

(2)

源代码：<hr size="2" color="#3366FF">

    7.制作两条 H = 2 pixels 的水平线，颜色为缺省值，分别有 Shade 和 没 Shade。

(1)

源代码： <hr size="2" noshade>

(2)

源代码： <hr size="2">

    看了上面的几种水平线效果，我们发现，当水平线的高度 H 设为“0 pixel”和“1 pixel”时，无论水平线有没有 Shade (阴影)，它在IE浏览器中都显示为 1 pixel 的细线。在论坛中曾经发现有些网友把高度H设置为小数数值，如：0.1之类的，以求达到 1 pixel 的细线的效果，实质上，在 Dreamweaver 网页编辑器里，属性面板是不能设置小数数值的，但如果我们直接在源代码里输入，属性面板就认了，可以显示出小数数值。同时，IE 浏览器把高度为 2 pixel 以下的水平线识别为 1pixel 。

    在制作水平线时我们制作了有 shade 和没有 shade 的，经过对比发现当水平线高度H为 2 pixels 以下时，shade 不起作用，只有到 2 pixels 以上时才看得到 shade 效果。

27> 如何自动加入网页更改后的日期？

    只需要在源文件<body></body>之间添加如下代码即可。

< Script Language=“JavaScript”><!--
document.write(“Last Updated:”+document.lastModified);
-->< /Script>

    在浏览器中的显示样式为：“Last Updated：2001/8/19”

28> 怎样控制弹出POPUP信息？

    有时，当我们点击链接时，会出现一些着重性说明的提示信息，也就是弹出信息。比如当某个链接还没有完成目标内容页的制作时，就可以应用POPUP信息解释一下。

    在网页中合适位置输入链接文字，选中，在属性面板中制作链接。在仍保持选中状态的前提下，单击快速启动板中的“Behavior”按钮，如图

dwquestion22.gif (8207 bytes)

    点击左上的“+”号，从列表中选中“Popun message”，在随后的窗口中输入需要提示的信息，如图

dwquestion23.gif (5435 bytes)

    设定该动作的鼠标事件（Events）为点击（Onclick）。在浏览器中预览效果如下

dwquestion24.gif (4753 bytes)

29> 隐藏浏览器中状态栏的URL地址信息的方法？

    浏览网页，当鼠标停留在链接上方时，在下面的状态栏中会自动显示该链接目标地址，考虑到安全方面的问题，有时我们需要把它重置为“零”，即设为空白。

    现在只需要在链接代码中作些手脚就可以实现了，如下

< a href="http://www.pconline.com.cn/pcedu" onMouseOver="window.status='none';return true">太平洋网络学院< /a>

30>如何改变状态栏里的提示文字？

    默认情况下，当网页被载入时，在状态栏里将显示该网页的地址等信息。想不想让它变的更有魅力呢？

    在DW“Behavior”行为板中，单击“+”号选择“Set Text Set”下的“Text Of Status Bar”选项，如图

dwquestion25.gif (4950 bytes)

    在“Set Text of Status Bar”窗口中输入类似“欢迎你光临本网站--网管留言”等Message信息。


DreamWeaver,经典50问(七)

31> 如何建立电子邮件的表单处理方式?

    表单应该是网页交互功能中必不可少的元素，表单的功能缘于信息的交互，因此表单的处理往往涉及到网络高级编程语言的使用，你或许说，哇！我不会编程呀！没关系，其实对于一些简单的表单内容处理靠电子邮件也可以实现。

先看下面的代码：

<form name="content" method="post" action="需要使用的处理程序" ></form>

    上面是一个典型的表单的HTML源代码，其中METHOD决定采用方式，包括POST和GET两种。ACTION也就是咱们上面说的处理程序，一般可通过ASP/PHP/CGI实现。

    那么用电子邮件怎么实现呢？action=mailto:bjbenben@sohu.com，这样当点击提交按钮后，就会弹出一个提示窗口，如下：

dwquestion26.gif (6434 bytes)

    单击“确定”表单内容会发送到指定的邮箱中。

32> 怎样制作规范的电子邮件链接？

    所谓的“电子邮件链接”即是当我们点击它时，浏览器会自动调用默认使用的邮件客户端程序发送电子邮件。

    输入“有问题MAIL ME”字样，鼠标拖拉选中，切换到属性面板，在LINK输入框中键入如下命令：

Mailto：bjbenben@sohu.com？Subject=网友来信&bc=其他电子邮件地址&bcc=其他电子邮件地址。如图：

dwquestion27.gif (1508 bytes)

    其中Mailto为邮件链接的协议，Subject 为邮件的标题，bc是同时抄送的邮件地址，bcc代表的也就是暗送了。

33> 如何制作“空链接”？

    空链接也就是，没有链接对象的链接，在空链接中，目标URL是用“#”来表示的。也就是说制作链接时，只要在属性板的LINK输入框中录入#标记，它就是个空链接了。

    空链接的出现涉及到多方面的因素，比如一些没有定期完成的页面，又为了保持页面显示上的一致（链接样式与普通文字样式的不同），就可以使用它了。

34> 点击空链接时，页面往往重置到页首端，如何处理？

    在浏览器里，当我们点击空链接时，它会自动将当前页面重置到首端，从而影响用户正常的阅读内容，我们当然希望它能保持不动了。

    这时，你能够用代码“javascript:void(null)”代替原来的“#”标记，回头看看，这个问题已经解决了。

35> 如何定制可自由在页面内跳转的链接？

    如果你经常在网上订阅一些免费的电子杂志，一定对这种“标签链接”不陌生了，通过一个类似目录的列表，可方便的跳转到页面内的任何部分，无疑它的使用是专门为“超长内容”网页设计的。

    先确定链接指向的位置，即屏幕跳转后停留的位置。进入“Object”面板的“Invisibles”部分，选中目标文本，单击“Insert Named Anchor”按钮，窗口如下

dwquestion28.gif (4816 bytes)

dwquestion29.gif (4989 bytes)

    在“Anchor Name”中键入标签名称，OK，这时在文本下面会自动出现红色虚线以区别开普通的文本内容，注意它们在浏览器中不会出现。

    然后就可以制作链接了，在属性板的LINK输入框录入“#nchor Name（刚才的名字）”。当然如果你想指向另外一页中的某个位置，也是可以的，把这个小尾巴放过去就行了。


DreamWeaver,经典50问(八)

36> 同时在一个图片上，作很多个链接，怎么办？

    这个问题也就是我们平常说的“图片热点”（Image HOT）了，当然在DW里还有另外一个名字叫“图象热区域”。

    选中图片，这时在属性面板左下的位置，有一个“Map”工具栏，其右边是三个用来圈定不同区域的按钮，如图

dwquestion30.gif (2015 bytes)

    以其中的矩形工具为例，选中后，鼠标停留在图片上会以一种“+”的形状显示出来，代表可以左右拖拉，完成后如图：

dwquestion31.gif (9001 bytes)

    依次你可以完成多个热点区域的链接制作。注意各区域不可重叠。

37> 怎样制作可以响应鼠标事件的翻转图片？

    在许多网页中，我们经常会看到一些栏目标题，当鼠标滑过时，能变成另外的样子。其实它们中很多是通过两张不同的图片来实现的，也就是所谓的“翻转图片”效果。

    当然首先你要提前准备两张大小完全一样的图片，以确保翻转时不会有什么视觉上的不适，单击“Object”面板上的“Rollover Image”

dwquestion32.gif (6679 bytes)

    弹出“翻转图片设置”窗口，如下：

dwquestion33.gif (7503 bytes)

    分别单击“Browse”按钮确定“Original image”和“Rollover image”的地址，注意一定要选中下面的“Preload Rollover image”复选框，否则在鼠标滑过的瞬间，会产生一定的下载延迟而影响效果。

38> 如何制作“漫天飞舞”的图片？

    在许多大型商业网站的首页中，你经常会看到不少来回飘来飘去的广告图片，点击后可以链接到指定的地址，在DW中这点是通过Timelines来实现的。

首先在网页中插入目标图片，同时选中它，单击快速启动板中的“Timelins”按钮进入“时间线”窗口，如图：

dwquestion34.gif (8999 bytes)

在时间轴1frame的位置鼠标右击，选择“Add Object”,这时时间轴上会出现一兰色色条（默认1-15frame），将镜头停在15frame处，同时移动页面内图片到运动的终点位置。

现在一个简单的运动动画已经完成了，你可以通过在中间添加keyframe的方法调整路径的曲折度。单击上方的右箭头按钮预览效果。

39> 怎样制作在页面中“静态悬浮”的图片？

所谓的“静态悬浮”也就是图片总是试图停留在网页中的某个位置，因此在视觉上有种跟着页面“走”的感觉，象悬浮着一样。

该效果的实现是通过javascript来完成的，一般要求有一定的编程能力。好在DW提供了制作该效果的固定插件，因此就显得简单多了。

首先你必须先下载stav插件,推荐地址:http://www.51step.com/download/dwplugbe/stav.zip,解压缩将里面的两个文件(其中包括图片文件Cross Browser Static Division.gif和网页文件Cross Browser Static Division.htm)都拷贝到DW安装目录Configuration\Objects\Common下。

重新启动DW,在Object(对象)面板中,你会看到最底部已经多了SI项,选中它在弹出的窗口中设定浮动层到上边和左边的距离,然后在图层中插入指定的内容（这里为图片）即可。

dwquestion35.gif (9073 bytes)

40> 如何使文字和图片内容共处？

    我们都知道，在DW中，图片对象往往是独占一行的，那么文字内容只能在与其平行的一行的位置上，怎么样才可以让文字围绕着图片显示呢？

    选中图片，在属性面板的右上方你能看到一个“Align”的属性选单，如图

dwquestion36.gif (4808 bytes)

    选择“Left”，这时你会发现文字已经均匀的排列在图片的右边了。


DreamWeaver,经典50问(九)

41> 实现多个窗口的连接?

    面板设计一直是DW的一大特色，到了DW4版本，所用到的面板已经相当多了，那么我们如何才能更高效的利用它呢？

    “窗口连接”就是一种方便大家自定义的技术功能，简单的说，就是可以根据需要将两个或更多个面板放到一个窗口中来。

鼠标点击拖动一个面板的Tab栏到两一个面板上，当你看到一个黑色边框时，松开鼠标，这时两个面板已经合二为一了，操作如图：

dwquestion37.gif (5968 bytes)

42> 如何在网页中隐藏一些内容？

    在网页设计中，有时我们需要在里面插入一些不要求显示出来的内容，比如流量统计系统，用户访问分析系统等等，这时就要考虑如何把他们隐藏起来，当然还有个前提就是，它们的存在不会影响其他网页元素的布局。

    单击“Object”面板中的“Layers”按钮，鼠标拖动创建一个新的图层，将需要隐藏的内容全部放进去，如图：

dwquestion38.gif (784 bytes)

    单击图层左上的小方框，标定它为选中状态，同时切换到属性面板，将Vis值设定为“Hidden”，如图：

dwquestion39.gif (2235 bytes)

    哇！所有的内容真的已经不见了

43> 怎样创建一个简单下拉菜单？

    下拉菜单是网页中再常见不过的了，由于它可以极大的节省网页空间，因而主要应用在需要进行多对象罗列的场合，比如友情连接列表，合作网站地址等等。

    DW中提供了一个再简单不过的制作方法，这样我们就不用写那些枯燥的代码啦！

进入“Object”面板的“Form”部分，如图：

dwquestion40.gif (5843 bytes)

    单击“Insert Jump Menu”按钮，弹出“下拉菜单”设置窗口：

dwquestion41.gif (4185 bytes)

    在“Text”中输入菜单项的名称；“Go To URL”中键入网址或使用“浏览”按钮选择。单击最上的“+”号可进行新菜单项的录入，所有项目都将在“Menu Items”中显示出来。

44> 如何制作一条宽度为1的细线？

    在DW中，尽管水平线是以“Line”形式出现的，但在制作细线时，它表现的并不尽如人意，主要是过粗，没有需要的细腻感！

    那么我们可以采取变通的方法以表格的应用来实现。

    在网页中插入一个1行1列的表格，将表格的“cellpadding”“cellspacing”都设置为“0”，同时将单元格的“bgcolor”设定为红色，当然你也可以使用其他的颜色来代替，“Height”设定高度为1。

    还有最关键的一步，查看源代码，将<td></td>中的“ ”去掉即可。

45>如何制作一个边框为1的方格？

    很明显，我们现在还是要通过表格的设置来完成。

    或许你会说，这还不简单嘛！建立一个1行1列的表格，然后将它的“Border”值设为1不就可以了。实际上，用这种方法制作的表格根本不是所说的边框为1的方格，而是要“粗”的多！

    同样先插入一个1行1列的表格，将表格的“border”、“cellpadding”设置为“0”，“cellspacing”设置为“1”。设定表格的“bgcolor”为红色（即为边框的颜色），同时设定单元格的“bgcolor”为白色（即同背景色），OK了。效果如下：

dwquestion42.gif (692 bytes)


DreamWeaver,经典50问(十)

46> 怎样设置根据不同的浏览器，返回不同的页面？

    浏览器不同，它所支持的技术和效果也不同。因而我们所设计的网页并不是在所有的浏览器中都能正常显示或最佳显示。这时一个判断浏览器的跳转就很必要了。

当用户用不同类型或版本的浏览器打开时，可以返回不同的页面，以保证用户的正常浏览。

    单击快速启动板中的“Behavior”按钮，点“+”号，在下拉列表中选择“Check Browse”，窗口如下：

dwquestion43.gif (7603 bytes)

    按照不同的类型依次设置即可。

47> 网页中可以随便拖动的对象是怎么建立的？

    访问网站时，经常能见到不少可以用鼠标拖动的元素，其中以图片居多，比如，一张广告图片挡住了你想浏览的内容，你完全可以用鼠标选中把它扔到一边去！

    制作这种效果是通过图层的“Drag Layer”行为实现的，单击Behavior面板中“+”号，选择“Drag Layer”，当然之前你必要保证目标图层处于选中状态，进行简单设置后就OK了。

48> 如何为网页添加一个外部的风格样式表（CSS）

    风格样式表有内部，外部之分，前面我们对网页元素进行直接修饰的设定都属内部之列。外部CSS引用是通过<LINK>标签实现的。

    <LINK>标签包括HREF;TYPE;REL属性设定。其中HREF:用来标定风格页文件的地址URL；REL:标示CSS的可选性：stylesheet/altermate；TYPE:用于标示风格语言类型:text/css。

49> 设定网页的Base（基地址）有什么用途？

    在“Object”面板的“Head”部分里有一个叫做“Base”的按钮，它就是用来设定网站基地址的，那么所谓的“基地址”究竟有什么作用呢？

    大家都知道，在DW中我们使用的链接方式都是相对的，而不是绝对的，也就是说只要改变了根地址，所有的指向也将跟着自动变化，这样的好处就是可移植性强。

    然而，有些时候我们恰恰需要它不变化，即强制它使用固定的地址，单击“Base”按钮，如图：

dwquestion45.gif (5209 bytes)

    在“Href”中键入基地址的URL，单击“确定”有效。

50> 如何精确的定位网页中的内容？

    这是一个说明性的技巧问题，因此我们把它放在了50问的最后来讲。以目前而言，DW网页内容定位主要是通过表格和图层两者实现的。

    表格主要是通过各个单元格来完成不同内容的布局，由于在网页中，我们可以完全把表格“虚化”（调整为浏览下不可见），因此使用起来很方便，另外一个优点就是表格不论对什么浏览器都是通用的，没有技术支持上诟病。

    相对而言，图层用起来就更加随意了，你可以根据需要任意的拖拽它。唯一的一点就是层只有在新版本的浏览器中才支持，不过依目前来看，应该也没什么障碍了！

    上面我们系统全面的介绍了在Dreamweaver中经常遇到的一些“经典”案例，希望对大家有所帮助！

全部完 >>

[上一页] [目录]